zoukankan      html  css  js  c++  java
  • qau国庆七天乐——A

    A - Who's in the Middle
    //先吐槽一波vj,不知道怎么回事,bits/stdc++.h不能用了。。。坑爹
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

    Description

    FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

    Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

    Input

    * Line 1: A single integer N 

    * Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

    Output

    * Line 1: A single integer that is the median milk output.

    Sample Input

    5
    2
    4
    1
    3
    5

    Sample Output

    3

    Hint

    INPUT DETAILS: 

    Five cows with milk outputs of 1..5 

    OUTPUT DETAILS: 

    #include<iostream>
    #include <algorithm>
    using namespace std;
    #define M 10500
    int main()
    {
        int n,i;
        int st[M];
        while(cin>>n){
            for(i=0;i<n;i++){
                cin>>st[i];
            }
            sort(st,st+n);
            if(n&1)
            cout<<st[n/2]<<endl;
            else
                cout<<(st[n/2]+st[n/2+1])/2<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法
    检测到有潜在危险的 Request.Form 值
    jQuery校验
    C#客户端的异步操作
    泛型(一)
    c#面试题汇总
    多线程(下)
    多线程(上)
    线程篇(二)
    线程篇(一)
  • 原文地址:https://www.cnblogs.com/upstart/p/5950826.html
Copyright © 2011-2022 走看看