zoukankan      html  css  js  c++  java
  • HDOJ 1076 An Easy Task(闰年计算)

    Problem Description
    Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

    Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

    Note: if year Y is a leap year, then the 1st leap year is year Y.

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains two positive integers Y and N(1<=N<=10000).

    Output
    For each test case, you should output the Nth leap year from year Y.

    Sample Input
    3
    2005 25
    1855 12
    2004 10000

    Sample Output
    2108
    1904
    43236

    Hint:
    We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

    题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年,
    如果year是闰年,则算第一个闰年。

    直接暴力做,并没有超时。

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                int year = sc.nextInt();
                int n = sc.nextInt();
                int nyear = 0;
                if((year%4==0&&year%100!=0)|(year%400==0)){
                    nyear=1;
                }//如果year是闰年,nyear就加一
                while(nyear<n){//当nyear小于n时,就循环
                    year++;
                    if((year%4==0&&year%100!=0)|(year%400==0)){
                        nyear++;
                    }//year是闰年,nyear就加加
                }
                System.out.println(year);
            }
        }
    
    }
    
  • 相关阅读:
    代码控制数据流量开关
    用wifi来调试应用程序
    详细解读LruCache类
    修改博客园默认的代码字体大小
    通过Gson解析Json数据
    Docker、Kubernetes的 CICD实现思路
    React中路由传参及接收参数的方式
    微信小程序开发工具调试没问题,真机调试Provisional headers are shown
    物联网卡三码
    【微信开发】-- 企业转账到用户
  • 原文地址:https://www.cnblogs.com/webmen/p/5739336.html
Copyright © 2011-2022 走看看