zoukankan      html  css  js  c++  java
  • HDOJ 1076 An Easy Task(闰年计算)

    Problem Description
    Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

    Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

    Note: if year Y is a leap year, then the 1st leap year is year Y.

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains two positive integers Y and N(1<=N<=10000).

    Output
    For each test case, you should output the Nth leap year from year Y.

    Sample Input
    3
    2005 25
    1855 12
    2004 10000

    Sample Output
    2108
    1904
    43236

    Hint:
    We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

    题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年,
    如果year是闰年,则算第一个闰年。

    直接暴力做,并没有超时。

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                int year = sc.nextInt();
                int n = sc.nextInt();
                int nyear = 0;
                if((year%4==0&&year%100!=0)|(year%400==0)){
                    nyear=1;
                }//如果year是闰年,nyear就加一
                while(nyear<n){//当nyear小于n时,就循环
                    year++;
                    if((year%4==0&&year%100!=0)|(year%400==0)){
                        nyear++;
                    }//year是闰年,nyear就加加
                }
                System.out.println(year);
            }
        }
    
    }
    
  • 相关阅读:
    前后台分离--概念相关
    dubbo概述
    memcache
    分布式系统事务
    2018书单索引
    Lucene原理之概念
    java 通用对象排序
    LightOJ1214 Large Division —— 大数求模
    LightOJ1336 Sigma Function —— 质因子分解、约数和为偶数
    LightOJ1245 Harmonic Number (II) —— 规律
  • 原文地址:https://www.cnblogs.com/webmen/p/5739336.html
Copyright © 2011-2022 走看看