zoukankan      html  css  js  c++  java
  • POJ-3687 Labeling Balls

    Description

    Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

    1. No two balls share the same label.
    2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

    Can you help windy to find a solution?

    Input

    The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

    Output

    For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

    Sample Input

    5
    
    4 0
    
    4 1
    1 1
    
    4 2
    1 2
    2 1
    
    4 1
    2 1
    
    4 1
    3 2
    

    Sample Output

    1 2 3 4
    -1
    -1
    2 1 3 4
    1 3 2 4
    


    题目大意:

    给你n个质量从1-n的球,让你给他们编号,使得

    1.任何两个球的编号都不一样

    2.编号满足一些约束,类似于“编号a的球比编号为b的球轻”

    然后给出m个约束条件。让你输出编号1-n的球的重量

    解题思路:

    裸拓扑排序,但是有一点,要输出的是1-n的球的重量。这点一定要注意,不然会无限wa

    先按照编号给出字典序最大的,然后从n-1一一对应。

    比如给出例子:

    1

    5 4

    1 4

    4 2

    5 3

    3 2

    先得到编号的序列2 4 3 5 1,再与5 4 3 2 1一一对应,得到ans[2] = 5, ans[4] = 4, ans[3] = 3, ans[5] = 2, ans[1] = 1

    从而找到输出答案1 5 3 4 2

    代码:

    #include <queue>
    #include <cstdio>
    #include <vector>
    #include <cstring>
    #include <algorithm>
    #include <functional>
    using namespace std;
    
    const int maxn = 200 + 5;
    
    int res[maxn];
    int n, m, in[maxn];
    int vis[maxn][maxn];
    vector<int> ans, vec[maxn];
    
    bool toposort(){
        int p, v, len;
        
        priority_queue<int> q;
        while(!q.empty()) q.pop();
        for(int i = 1; i <= n; ++i){
            if(!in[i]) q.push(i);
        }
        
        while(!q.empty()){
            p = q.top();
            ans.push_back(p);
            q.pop();
            
            len = vec[p].size();
            for(int i = 0; i < len; ++i){
                v = vec[p][i];
                --in[v];
                if(!in[v]) q.push(v);
            }
        }
        
        if(ans.size() == n) return true;
        else return false;
    }
    int main()
    {
        int t, a, b;
        scanf("%d", &t);
        while(t--){
            scanf("%d%d", &n, &m);
            
            memset(in, 0, sizeof(in));
            memset(vis, 0, sizeof(vis));
            for(int i = 0; i <= n; ++i) vec[i].clear();
            
            for(int i = 0; i < m; ++i){
                scanf("%d%d", &a, &b);
                if(!vis[b][a]){
                    vec[b].push_back(a);
                    vis[b][a] = 1;
                    ++in[a];
                }
            }
            
            ans.clear();
            if(toposort()) {
                int len = ans.size();
                for(int i = 0, j = n; i < len; ++i, --j){
                    res[ans[i]] = j;
                }
                for(int i = 1; i <= n; ++i){
                    printf("%d%c", res[i], (i == n ? '
    ' : ' '));
                }
            }else puts("-1");
        }
        return 0;
    }


  • 相关阅读:
    C#的一些基本问题
    Mac ssh连接远程服务器,并实现文件的上传和下载
    Redis 持久化
    Redis 数据类型
    @dynamic 与 @synthesize 关键词详解
    Redis介绍及安装
    crontab的用法
    修改文件权限
    Linux目录结构
    一些命令
  • 原文地址:https://www.cnblogs.com/wiklvrain/p/8179441.html
Copyright © 2011-2022 走看看