zoukankan      html  css  js  c++  java
  • poj2492 A Bug's Life【并查集】

    Background 
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
    Problem 
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
    Input
    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
    Output
    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
    Sample Input
    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4
    Sample Output
    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!
    Hint
    Huge input,scanf is recommended.

    假设虫子只和异性交流 现在告诉你交流的虫子号码 问这个假设正确不正确

    现在发现并查集就是找节点和父节点的关系 rank数组就是x对fx的关系 有时候不考虑方向比如这一题

    像这种题目更新的时候 fx的rank应该是 x对fx的关系加fy对y的关系加x对y的关系

    输出之间要空行!


    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    const int maxn = 2005;
    int t, n, m;
    int ran[maxn], parent[maxn];
    
    void init(int n)
    {
        for(int i = 0; i < n; i++){
            ran[i] = 0;
            parent[i] = i;
        }
    }
    
    int fin(int x)
    {
        if(x == parent[x]) return x;
        
        int t = parent[x];
        parent[x] = fin(parent[x]);
        ran[x] = (ran[x] + ran[t]) % 2;
        return parent[x];
    }
    
    void mer(int x, int y)
    {
        int tx = fin(x);
        int ty = fin(y);
    
        if(tx != ty){
            parent[tx] = ty;
            ran[tx] = (ran[x] + 1 + ran[y]) % 2;
        }
    
    }
    
    int main()
    {
        scanf("%d", &t);
        for(int i = 1; i <= t; i++){
            scanf("%d%d", &n, &m);
            init(n);
            bool flag = true;
            for(int j = 0; j < m; j++){
                int a, b;
                scanf("%d%d", &a, &b);
                if(fin(a) == fin(b)){
                    if(ran[a] == ran[b])
                    {
                        flag = false;
                    }
                }
                else{
                    mer(a, b);
                }
            }
    
            if(!flag){
                printf("Scenario #%d:
    Suspicious bugs found!
    
    ", i);
            }
            else{
                printf("Scenario #%d:
    No suspicious bugs found!
    
    ", i);
            }
        }
        return 0;
    }
    


  • 相关阅读:
    LeetCode(75) Sort Colors
    大众点评2015 在线笔试(1)
    百度2015 在线笔试题(3)
    百度2015 在线笔试题(2)
    百度2015 在线笔试题(1)
    其他 之网站分享插件
    Flask框架 之request对象
    Flask框架 之路由
    Flask框架 之第一个Flask程序
    微信 之网页授权登录
  • 原文地址:https://www.cnblogs.com/wyboooo/p/9643409.html
Copyright © 2011-2022 走看看