zoukankan      html  css  js  c++  java
  • hdu2488 dfs

    G - 深搜 基础

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

    Submit Status

    Description

    Background
    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

    Problem
    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

    Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
    If no such path exist, you should output impossible on a single line.

    Sample Input

    3
    1 1
    2 3
    4 3

    Sample Output

    Scenario #1:
    A1
    
    Scenario #2:
    impossible
    
    Scenario #3:
    A1B3C1A2B4C2A3B1C3A4B2C4
    
    解析见代码
    代码:

    /*
    hdu2488 深搜,判断能否走完全图,并要求输出路径
    首先是能否走完全图的判断,深搜函数加一个参数step,
    来判断是否走完全图,同时用flag进行标记,方便输出两种情况
    再就是路径如何保存,只需要保存每一步的x,y坐标即可,使用
    一个二位组就可以保存。同时因为vis数组是以步数为标准来进行保存的
    其值会随着递归回溯不断更新,始终保证是最新解,step=p*q标志着递归
    成功,按照步数输出即可,注注意格式要求的是先输纵坐标后输横坐标
    */
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <stack>
    #include <queue>
    using namespace std;
    const int maxn=100;
    int vis[maxn*maxn][2];//vis二维数组,前一个参数代表是第几步,后一个参数0代表横坐标,后一个参数代表纵坐标。
    int p,q,step,flag;
    char maps[maxn][maxn];
    int f[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//输出要求按字典序输出,同时注意大写字母是列编号,所以方向数组应该是按照先y后x字典序开
    int ans=0;
    int dis[maxn][maxn];
    void dfs(int x,int y,int step)
    {
        if(step==p*q&&flag==0)
        {
           cout<<"Scenario #"<<++ans<<":"<<endl;
            for(int i=0;i<p*q;i++)
            printf("%c%d",'A'+vis[i][1],vis[i][0]+1);
            flag=1;
            cout<<endl<<endl;//输出格式要求
            return;
        }
        for(int i=0;i<8;i++)
        {
            int a=x+f[i][0];
            int b=y+f[i][1];
            if(a>=0&&a<p&&b>=0&&b<q&&!dis[a][b])
            {
                dis[a][b]=1;
                vis[step][0]=a;
                vis[step][1]=b;
                dfs(a,b,step+1);
                 dis[a][b]=0;//回溯时该点状态恢复
                if(flag) return;//相当于一个剪枝操作,找到就返回,大大提高了程序工作效率
            }
        }
    }
    int main()
    {
        int n;
        cin>>n;
      while(n--)
      {
            memset(dis,0,sizeof(dis));
            cin>>p>>q;
            flag=0;
            dis[0][0]=1;//标记数组,避免重复搜索
            vis[0][0]=0,vis[0][1]=0;
             dfs(0,0,1);
            if(!flag)//用flag来判断最终是否走完全图
            {
                cout<<"Scenario #"<<++ans<<":"<<endl;
        cout<<"impossible"<<endl<<endl;

            }
      }
        return 0;
    }

  • 相关阅读:
    【IBM】netperf 与网络性能测量
    netperf 网络性能测试
    Netperf测试技巧
    网络测试工具--Iperf、Netperf 、MZ
    iozone
    iozone的使用与介绍-20191105
    XRDP freerdp
    性能工具 stream 最新版本5.10 The STREAM benchmark
    Linux学习之路-Linux-at及cron命令【7】---20171215
    centos7基于luks对磁盘进行加密
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5568255.html
Copyright © 2011-2022 走看看