zoukankan      html  css  js  c++  java
  • 简单的字符串比较题 POJ 1936

    Description

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

    Input

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

    Output

    For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

    Sample Input

    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter
    

    Sample Output

    Yes
    No
    Yes
    No



    #include<iostream>
    #include<string.h>
    using namespace std;
    int main(long i,long j)
    {
    char s[100000],t[100000];
    while(cin>>s>>t)
    {
    long lens=strlen(s);
    long lent=strlen(t);
    i=0;
    j=0;
    while(true)
    {
    if(i==lens)
    {
    cout<<"YES"<<endl;
    break;
    }
    if(j==lent)
    {
    cout<<"NO"<<endl;
    break;
    }
    if(s[i]==t[j])
    {
    i++;
    j++;
    }
    else j++;
    }
    memset(s,'',lens);
    memset(t,'',lent);
    }
    return 0;
    }

    这是一道简单题,只需比较就行了,当s串存在t串中时,输出YES;否则输出NO

  • 相关阅读:
    SpringMVC 高级开发(异常页面处理,json传输数据,文件上传)
    SpringMVC中的Controller方法的(返回值/参数类型)
    SpringMVC的其他注解
    SpringMVC的整合,基于注解
    SpringMVC入门程序:helloWorld
    SpringMVC入门
    SpringAOP事务的实现
    仅需三步,即可在Vue项目中配置sass
    前端常用的设计模式
    call和apply的区别及其用法
  • 原文地址:https://www.cnblogs.com/zdblog/p/3670824.html
Copyright © 2011-2022 走看看