zoukankan      html  css  js  c++  java
  • 1079 Total Sales of Supply Chain (25 分)

    1079 Total Sales of Supply Chain (25 分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (105​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki​​ ID[1] ID[2] ... ID[Ki​​]

    where in the i-th line, Ki​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj​​. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010​​.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    

    Sample Output:

    42.4
    思路
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    #include<string.h>
    #include<cstdio>
    #include <unordered_map>
    #include<cmath>
    
    using namespace std;
    vector<vector<int>> graph;
    int units[100005];
    double sum=0;
    int n;
    double p,r;
    
    void dfs(int root,int depth)
    {
        if(graph[root].size()==0)
        {
            //cout<<p<<" "<<pow(1+r/100,depth)<<" "<<units[root]<<endl;
            sum+=p*pow(1+r/100,depth)*units[root];
        }
        for(auto num:graph[root])
            dfs(num,depth+1);
    }
    int main()
    {
    
        scanf("%d%lf%lf",&n,&p,&r);
        graph.resize(n);
        for(int i=0;i<n;i++)
        {
            int k,unit,id;
            scanf("%d",&k);
            if(k==0)
            {
                scanf("%d",&unit);
                units[i]=unit;
                continue;
            }
            for(int j=0;j<k;j++)
            {
                scanf("%d",&id);
                graph[i].push_back(id);
            }
        }
        dfs(0,0);
        printf("%.1f",sum);
        return 0;
    }
  • 相关阅读:
    CentOS 7 firewalld vsftpd开放端口
    sqlalchemy操作----多表关联
    sqlalchemy 或者pysql 连接数据库时支持中文操作
    sqlalchemy操作----外键关联,relationship
    sqlalchemy操作----建表 插入 查询 删除
    python 操作mysql
    指针和二维数组的关系要点简单分析
    二维数组基本操作练习题
    单独取出整数的个位,十位,百位,以及素数的小综合题
    LeetCode | Add Two Numbers II
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10329952.html
Copyright © 2011-2022 走看看