zoukankan      html  css  js  c++  java
  • NYOJ217a letter and a number

    a letter and a number

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
     
    描述
    we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
    Give you a letter x and a number y , you should output the result of y+f(x).
     
    输入
    On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
    输出
    for each case, you should the result of y+f(x) on a line
    样例输入
    6
    R 1
    P 2
    G 3
    r 1
    p 2
    g 3
    样例输出
    19
    18
    10
    -17
    -14
    -4
     
    
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        int n,x,b;
        char a;
        scanf("%d",&n);
        getchar();
        while(n--)
        {
            scanf("%c %d",&a,&b);
            getchar();
            if(a>='A'&&a<='Z')
                printf("%d\n",a-'A'+1+b);
            else if(a>='a'&&a<='z')
                printf("%d\n",-(a-'a'+1)+b);
        }
        return 0;
    }
    
                    
            
  • 相关阅读:
    JdbcTemplate
    Spring AOP——基于XML的进阶案例
    Spring
    面试题
    切面编程
    选择题
    Spring核心概念
    缓存
    BFC 神奇背后的原理
    git 教程
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_08_02000.html
Copyright © 2011-2022 走看看