zoukankan      html  css  js  c++  java
  • Macos下制作可启动的u盘(转)

    1. Download the desired file
    2. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
    3. Convert the .iso file to .img using the convert option of hdiutil:
      hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso
      Note: OS X tends to put the .dmg ending on the output file automatically. Rename the file by typing:
      mv /path/to/target.img.dmg /path/to/target.img
    4. Run diskutil list to get the current list of devices
    5. Insert your flash media
    6. Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2)
    7. Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command - in the previous example, N would be 2)
    8. Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).
      Note: Using /dev/rdisk instead of /dev/disk may be faster.
      Note: If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.
      Note: If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.
    9. Run diskutil eject /dev/diskN and remove your flash media when the command completes

    Now the USB stick is ready. Boot the device that you want from the USB stick.

  • 相关阅读:
    线程与进程
    进程间通信之信号量与信号灯
    进程间通信之消息队列
    进程间通信之共享内存
    进程间通信之信号
    进程间通信之管道
    软件需求分析
    团队介绍
    EF Core(1.DBFirst)
    7.基本方式调用Api(http api)
  • 原文地址:https://www.cnblogs.com/zhenfei/p/12729348.html
Copyright © 2011-2022 走看看