zoukankan      html  css  js  c++  java
  • poj-3370-Halloween treats

    Halloween treats

    Time Limit: 2000MS

     

    Memory Limit: 65536K

    Total Submissions: 5574

     

    Accepted: 2082

     

    Special Judge

    Description

    Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

    Your job is to help the children and present a solution.

    Input

    The input contains several test cases.
    The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

    The last test case is followed by two zeros.

    Output

    For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

    Sample Input

    4 5

    1 2 3 7 5

    3 6

    7 11 2 5 13 17

    0 0

    Sample Output

    3 5

    2 3 4

    Source

    Ulm Local 2007

    解题思路:

    1、  用抽屉原理 和poj-2356题一样。

    注意事项: 本题定义和的时候必须是64位  (long long).否则会溢出。

    抽屉原理:

    http://baike.baidu.com/view/8899.htm

    程序代码:

    #include<stdio.h>

    #include<string.h>

    #define N 100005

    int a[N],b[N],c[N];                                   //和 poj-2356题差不多 都是抽屉原理

    int main()

    {

        int n,m,i,j,k,t,f;

        long long s;                                  // 只有定义为long long型 才不会溢出 。

        while(scanf("%d %d",&m,&n)&&(m!=0||n!=0))

        {

            memset(b,0,sizeof(b));

            memset(c,0,sizeof(c));

            for(i=0;i<n;i++)

            {

                scanf("%d",&a[i]);                          //数组a 保存原始数据。

            }

            s=0;

            k=0;

            t=0;

            f=0;

            for(i=0;i<n;i++)

            {

                s=s+a[i];                                   //依次求和。并立即做出判断

                if(s%m==0)

                {

                    f=1;

                    t=i+1;

                    k=0;

                    break;                                     //得到 想要的结果就要跳出循环。

                }

                else if(b[s%m]==0)               

                {

                    b[s%m]=i+1;

                    f=0;                                     // f 变量为了控制是否有结果输出。

                }

                else if(b[s%m]!=0)

                {

                    f=1;

                    t=i+1;

                    k=b[s%m];                               //  和的余数第二次 出现的保存起来

                    break;

                }

                else

                f=0;

            }

            if(f==1)

            {

                for(i=k+1;i<=t;i++)

                {                             

                    if(i==k+1)

                    printf("%d",i);                       //  注意本题要求的是输出第几个数。

                    else

                    printf(" %d",i);

                }

                printf(" ");

            }

            else

            printf("no sweets ");                       // 原理上肯定都能分到糖。

           

        }

    }

    //  c++ 程序

    /*#include<iostream>

    #include<stdlib.h>

    #include<stdio.h>

    #include<string.h>

    using namespace std;

    int a[100000] , mod[100000] ;

    int main()

    {

        int c , n ;

        while ( scanf("%d%d",&c,&n) &&(c+n))

        {

            int i , j ;

            for ( i = 0 ; i < n ; i ++ )

                {

                    scanf("%d",&a[i]) ;

                     mod[i] = -2 ;            //将mod初始化为-2

                }

            mod[0]=-1 ;                       //mod[0]为-1,就是假设存在a[-1],且a[-1]是n的倍数,这样就可以把两种情况写在一起

            long long sum = 0 ;            //直接用sum,省去了另开数组的空间

    for ( i = 0 ; i < n ; i ++ )

            {

                sum += a[i] ;

                if ( mod [ sum % c ] != -2 )          //如果在i之前有与sum对n同余的数,则可以输出答案,

                {

                    for ( j = mod [ sum % c ] + 1 ; j <= i ; j ++ )

                    {

                        printf("%d",j+1);;

                        if ( i != j )

                     printf("");

                    }

                    printf(" ");

                    break;

                }

                mod [sum%c] = i ;                          //记录余数对应的是i

            }

        }

        return 0;

    }*/

  • 相关阅读:
    几种回文算法的比较
    算法与数据结构(五)树表的查找
    算法与数据结构(四)利用哈夫曼树编码解码
    算法与数据结构(三)线性表的查找算法
    主存和cache的地址映射
    算法与数据结构(二)三元组矩阵行列式的计算(用递归)
    算法与数据结构(一)将一个数组中的各节点按照层次遍历插入构成完全二叉树
    服务器被攻击,我真是个人才。
    想学嘛,不想学? 自学是门手艺
    想学嘛,技术人, 请不要封闭自己
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3241875.html
Copyright © 2011-2022 走看看