zoukankan      html  css  js  c++  java
  • HITRed and Black DFS

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.


    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    • '.' - a black tile
    • '#' - a red tile
    • '@' - a man on a black tile(appears exactly once in a data set)


    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output
    45
    59
    6
    13


            用系统栈DFS搜索:
    #include<stdio.h>
    #include<memory.h>
    const int MAXN=20+2;
    void dfs(int i,int j);
    char maze[MAXN][MAXN],vis[MAXN][MAXN];
    int w,h;
    int main()
    {
    	//freopen("in.in","r",stdin);
    	int i,j,k;
    	while(scanf("%d%d",&w,&h)&&(w||h))
    	{
    		memset(vis,0,sizeof(vis));
    		for(i=0;i<h;)
    			scanf("%s",maze[i++]);
    		for(i=0,k=0;i<h;i++){
    			for(j=0;j<w;j++)
    				if(maze[i][j]=='@'){k=1;break;}
    			if(k)break;
    		}
    		dfs(i,j);
    		for(i=0,k=0;i<h;i++)
    			for(j=0;j<w;j++)
    				if(vis[i][j])k++;
    		printf("%d\n",k);
    	}
    	return 0;
    }
    
    void dfs(int i,int j)
    {
    	if(i<0||i>=h||j<0||j>=w||vis[i][j]||maze[i][j]=='#')return;
    	vis[i][j]=1;
    	            dfs(i-1,j);
    	dfs(i,j-1);            dfs(i,j+1);
    	            dfs(i+1,j);
    }

  • 相关阅读:
    JS基础知识点2
    JS基础知识
    CSS-弹性盒子
    css取值
    css语法和规则
    第7-9章作业汇总
    第7-9章作业---第3题
    第四次作业——第一题
    第四次作业-第二题
    第四次作业---第四题
  • 原文地址:https://www.cnblogs.com/zhsl/p/2743640.html
Copyright © 2011-2022 走看看