zoukankan      html  css  js  c++  java
  • USACO1.2.5Dual Palindromes

    Dual Palindromes
    Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

    A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

    The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

    Write a program that reads two numbers (expressed in base 10):

    • N (1 <= N <= 15)
    • S (0 < S < 10000)

    and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

    Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

    PROGRAM NAME: dualpal

    INPUT FORMAT

    A single line with space separated integers N and S.

    SAMPLE INPUT (file dualpal.in)

    3 25
    

    OUTPUT FORMAT

    N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

    SAMPLE OUTPUT (file dualpal.out)

    26
    27
    28

    题解:模拟。没啥技巧性的东西。
    /*
    ID:spcjv51
    PROG:dualpal
    LANG:C
    */
    #include<stdio.h>
    int ans[100];
    int len;
    void conversion(int i,int b)
    {
        len=0;
        while(i)
        {
            len++;
            ans[len]=i%b;
            i/=b;
        }
    
    }
    
    int judge()
    {
        int i,ll;
        ll=len/2;
        for(i=1; i<=ll; i++)
            if(ans[i]!=ans[len-i+1]) return 0;
        return 1;
    }
    int main(void)
    {
        FILE *fin=fopen("dualpal.in","r");
        FILE *fout=fopen("dualpal.out","w");
        int i,j,k,m,sum,n;
        fscanf(fin,"%d%d",&n,&m);
        k=0;
        while(k<n)
        {
            m++;
            sum=0;
            for(i=2; i<=10; i++)
            {
                conversion(m,i);
                if(judge()) sum++;
                if(sum==2)
                {
                    fprintf(fout,"%d\n",m);
                    k++;
                    break;
                }
    
            }
        }
        fclose(fin);
        fclose(fout);
        return 0;
    
    }
    
    
    

      

     
  • 相关阅读:
    java事件处理(贪吃蛇)
    九九乘法表
    使用文件包含指令include
    jsp页面的基本构成
    软件测试博客

    成功职业女性处世的10大秘诀
    再见啦,冬冬妹
    网摘——杜晓眼眼中的尹珊珊:什么都要,什么都要得到
    网摘——事关“工程师思维”
  • 原文地址:https://www.cnblogs.com/zjbztianya/p/2852404.html
Copyright © 2011-2022 走看看