zoukankan      html  css  js  c++  java
  • 69前K个高频单词(692)

    作者: Turbo时间限制: 1S章节: 哈希表

    晚于: 2020-08-19 12:00:00后提交分数乘系数50%

    截止日期: 2020-08-26 12:00:00

    问题描述 :

    给一非空的单词列表,返回前 k 个出现次数最多的单词。

    返回的答案应该按单词出现频率由高到低排序。如果不同的单词有相同出现频率,按字母顺序排序。

    示例 1:

    输入: ["i", "love", "leetcode", "i", "love", "coding"], k = 2

    输出: ["i", "love"]

    解析: "i" 和 "love" 为出现次数最多的两个单词,均为2次。

        注意,按字母顺序 "i" 在 "love" 之前。

    示例 2:

    输入: ["the", "day", "is", "sunny", "the", "the", "the", "sunny", "is", "is"], k = 4

    输出: ["the", "is", "sunny", "day"]

    解析: "the", "is", "sunny" 和 "day" 是出现次数最多的四个单词,

        出现次数依次为 4, 3, 2 和 1 次。

    输入说明 :

    首先输入单词列表的单词数目n,

    然后输入n个单词,以空格分隔

    最后输入整数k。

    假定 k 总为有效值, 1 ≤ k ≤ 集合元素数。

    输入的单词均由小写字母组成。

    输出说明 :

    按题目要求输出,单词之间以一个空格分隔,行首和行尾无多余空格。

    输入范例 :

    输出范例 :

    #include <iostream> 
    #include <vector>
    #include <string.h>
    #include <unordered_map>
    #include <algorithm>
    using namespace std;
    class Solution {
    public:
        static bool cmp(const pair<string,int> &a,const pair<string,int> &b)//记得必须加static 
        {
            if(a.second==b.second)
                 return a.first<b.first;//出现次数相同,按字母从小到大排序 
            else
                return a.second>b.second;
        }
            
        vector<string> topKFrequent(vector<string>& words, int k) 
        {
            unordered_map<string,int> map;
            for(const auto &i:words)//统计每个单词的出现次数 
                map[i]+=1;
            vector<pair<string,int>> M(map.begin(),map.end());//把map存入vector,为了后面的按要求排序 
            sort(M.begin(),M.end(),cmp);
            vector<string> res;
            for(const auto &b:M)
            {
                if(k--==0)
                    break;
                res.push_back(b.first);
            }
        return res;
        }
    };
    int main()
    {
        int m,k;
        string str;
        cin>>m;
        vector<string> word;
        for(int i=0;i<m;i++)
        {
            cin>>str;
            word.push_back(str);
        }
        cin>>k;
        vector<string> res=Solution().topKFrequent(word,k);
        for(int i=0;i<res.size();i++)
        {
            if(i>0)
                cout<<" "<<res[i];
            else
                cout<<res[i];
        }
            
    }
  • 相关阅读:
    MyBatis入门案例、增删改查
    Hibernate第三次测试错题解析
    HIbernate二级缓存
    Hibernate组件映射
    java 序列化
    圈复杂度(Cyclomatic Complexity)
    ASE加、解密
    异常Exception
    动态代理(jdk--cglib)
    java.lang.Class类
  • 原文地址:https://www.cnblogs.com/zmmm/p/13645753.html
Copyright © 2011-2022 走看看