zoukankan      html  css  js  c++  java
  • 足球赛

    Description

    Petya loves football very much. One day, as he was watching a football match, he was writing the players' current positions on a piece of paper. To simplify the situation he depicted it as a string consisting of zeroes and ones. A zero corresponds to players of one team; a one corresponds to players of another team. If there are at least 7 players of some team standing one after another, then the situation is considered dangerous. For example, the situation 00100110111111101 is dangerous and 11110111011101 is not. You are given the current situation. Determine whether it is dangerous or not.

    Input

    The first input is an integer N, represents the number of cases.
    Then there are N cases:
    The first input line contains a non-empty string consisting of characters "0" and "1", which represents players. The length of the string does not exceed 100 characters. There's at least one player from each team present on the field.

    Output

    Print "YES" if the situation is dangerous. Otherwise, print "NO".

    Sample Input

    2 001001 1000000001

    Sample Output

    NO YES

    HINT

     

    Source

    万圣节

    #include<stdio.h>
    #include<string.h>
    int main()
    {
        int n, i, j, a;
        scanf("%d",&a);
        while(a--)
        {   
             j = 0;
             char str[120];
             scanf("%s",str);
             n = strlen(str);
             for( i = 0; i <= n - 5; i++ )
             {
                  if(( str[i] == str[i+1] ) && ( str[i+1] == str[i+2] ) && ( str[i+2] == str[i+3] ) && ( str[i+3] == str[i+4] ) && ( str[i+4] == str[i+5] ) && ( str[i+5] == str[i+6] ))
                       j = 1;
             }
             if( j == 1)
                 printf("YES\n");
             else
                 printf("NO\n");
        }
        return 0;
    }

  • 相关阅读:
    C语言打印记事本内搜索字符串所在行信息
    原创:C语言打开、下载、删除网页,统计网页字符个数
    JAVA GUI编程学习笔记目录
    13.JAVA之GUI编程将程序打包jar
    12.JAVA之GUI编程打开与保存文件
    11.JAVA之GUI编程菜单
    10.JAVA之GUI编程弹出对话框Dialog
    php中的一些不常见的问题foreach/in_array[开发篇]
    微软职位内部推荐-Senior SDE
    微软职位内部推荐-SDE II
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2250528.html
Copyright © 2011-2022 走看看