zoukankan      html  css  js  c++  java
  • 足球赛

    Description

    Petya loves football very much. One day, as he was watching a football match, he was writing the players' current positions on a piece of paper. To simplify the situation he depicted it as a string consisting of zeroes and ones. A zero corresponds to players of one team; a one corresponds to players of another team. If there are at least 7 players of some team standing one after another, then the situation is considered dangerous. For example, the situation 00100110111111101 is dangerous and 11110111011101 is not. You are given the current situation. Determine whether it is dangerous or not.

    Input

    The first input is an integer N, represents the number of cases.
    Then there are N cases:
    The first input line contains a non-empty string consisting of characters "0" and "1", which represents players. The length of the string does not exceed 100 characters. There's at least one player from each team present on the field.

    Output

    Print "YES" if the situation is dangerous. Otherwise, print "NO".

    Sample Input

    2 001001 1000000001

    Sample Output

    NO YES

    HINT

     

    Source

    万圣节

    #include<stdio.h>
    #include<string.h>
    int main()
    {
        int n, i, j, a;
        scanf("%d",&a);
        while(a--)
        {   
             j = 0;
             char str[120];
             scanf("%s",str);
             n = strlen(str);
             for( i = 0; i <= n - 5; i++ )
             {
                  if(( str[i] == str[i+1] ) && ( str[i+1] == str[i+2] ) && ( str[i+2] == str[i+3] ) && ( str[i+3] == str[i+4] ) && ( str[i+4] == str[i+5] ) && ( str[i+5] == str[i+6] ))
                       j = 1;
             }
             if( j == 1)
                 printf("YES\n");
             else
                 printf("NO\n");
        }
        return 0;
    }

  • 相关阅读:
    推荐系统相关算法
    特征的生命周期
    数学知识索引
    蓄水池(Reservoir_sampling)抽样算法简记
    数赛刷题代码学习及课程学习链接
    逻辑回归(LR)总结复习
    我的面试问题记录
    开发中遇到的一些问题
    K-Means聚类和EM算法复习总结
    常见概率分布图表总结
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2250528.html
Copyright © 2011-2022 走看看