zoukankan      html  css  js  c++  java
  • HDU 6090 Rikka with Graph【思维题】

    Rikka with Graph

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 679    Accepted Submission(s): 397


    Problem Description
    As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

    For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

    Then, we can define the weight of the graph G (wG) as ni=1nj=1dist(i,j).

    Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

    Yuta wants to know the minimal value of wG.

    It is too difficult for Rikka. Can you help her?  

    In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).
     

    Input
    The first line contains a number t(1t10), the number of the testcases. 

    For each testcase, the first line contains two numbers n,m(1n106,1m1012).
     

    Output
    For each testcase, print a single line with a single number -- the answer.
     

    Sample Input
    1 4 5
     

    Sample Output
    14
     

    Source


    #include <iostream>  
    #include <cstdio>  
    #include <cstring>  
    #include <algorithm>  
    #include <cmath>  
    #include <queue>  
    #include <string>  
    #include <map>  
    #include <cstring>  
    #define INF 0x3f3f3f3f  
    #define ms(x,y) memset(x,y,sizeof(x))  
    using namespace std;
    
    typedef long long ll;
    typedef unsigned long long ull;
    typedef pair<int, int> P;
    
    const int maxn = 30010;
    const int mod = 998244353;
    
    #define lson l,m,rt<<1  
    #define rson m+1,r,rt<<1|1  
    
    int main()
    {
    	std::ios::sync_with_stdio(false);
    	int t;
    	cin >> t;
    	while (t--)
    	{
    		ll n, m, ans = 0;
    		cin >> n >> m;
    		if (m <= n - 1)
    		{
    			ll p = m + 1, q = n - p;	//p连接的点,q孤立的点
    			ans = (2 * p - 2)*(p - 1) + q*(q - 1)*n + 2 * p*q*n;
    		}
    		else if (m <= (n - 1)*n / 2)
    		{
    			m = (n - 1)*n / 2 - m;
    			ans = n*(n - 1);
    			ans += 2 * m;
    		}
    		else
    		{
    			ans = n*(n - 1);
    		}
    		cout << ans << endl;
    	}
    	return 0;
    }



    Fighting~
  • 相关阅读:
    Adding Swap Files
    Creating a Swap Partition
    linux删除或隐藏命令历史记录history
    Unix系统解压tar包时出现@LongLink错误
    【白话经典算法系列之十七】 数组中只出现一次的数 其他三次
    MapReduce原理及其主要实现平台分析
    二叉搜索树转换为有序双向链表
    实现O(1)获取最大最小值的栈----java
    对线性回归,logistic回归和一般回归的认识
    SMO优化算法(Sequential minimal optimization)
  • 原文地址:https://www.cnblogs.com/Archger/p/8451600.html
Copyright © 2011-2022 走看看