zoukankan      html  css  js  c++  java
  • 算法总结——主席树(poj2104)

    题目:

    Description

    You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
    That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
    For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

    Input

    The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
    The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
    The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

    Output

    For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

    Sample Input

    7 3
    1 5 2 6 3 7 4
    2 5 3
    4 4 1
    1 7 3

    Sample Output

    5
    6
    3

    Hint

    This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

    Source

    Northeastern Europe 2004, Northern Subregion

    题解:

      主席树模板题,关于主席树的知识见下:

      

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cmath>
    #include<ctime>
    #include<cctype>
    #include<cstring>
    #include<string>
    #include<algorithm>
    using namespace std;
    const int N=1e5+5;
    struct node
    {
      int l,r,sum;
    }tree[N*20];
    inline int R()
    { 
      char c;int f=0,i=1;
      for(c=getchar();(c<'0'||c>'9')&&c!='-';c=getchar());
      if(c=='-') i=-1,c=getchar(); 
      for(;c<='9'&&c>='0';c=getchar())
        f=(f<<3)+(f<<1)+c-'0';
      return f*i;
    }
    int num[N],a[N],n,m,root[N],tot;
    inline void build(int v,int &k,int l,int r)
    {
      tree[++tot]=tree[k],k=tot;tree[k].sum+=1;
      if(l==r)  return;
      int mid=(l+r)/2;
      if(v<=mid)  build(v,tree[k].l,l,mid);
      else build(v,tree[k].r,mid+1,r);
    }
    inline int query(int t1,int t2,int l,int r,int k)
    {
      if(l==r)  return l;
      int mid=(l+r)/2,tot=tree[tree[t2].l].sum-tree[tree[t1].l].sum;
      if(k<=tot)  return query(tree[t1].l,tree[t2].l,l,mid,k);
      else return query(tree[t1].r,tree[t2].r,mid+1,r,k-tot);
    }
    int main()
    {
      //freopen("a.in","r",stdin);
      while(scanf("%d%d",&n,&m)!=EOF)
      {
        int p,q,k;tot=1;
        for(int i=1;i<=n;i++)
          num[i]=R(),a[i]=num[i];
        sort(a+1,a+n+1); 
        for(int i=1;i<=n;i++)
          num[i]=lower_bound(a+1,a+n+1,num[i])-a;
        for(int i=1;i<=n;i++)
        {
          root[i]=root[i-1];build(num[i],root[i],1,n);
        }
        for(int i=1;i<=m;i++)
        {
          p=R(),q=R(),k=R();
          cout<<a[query(root[p-1],root[q],1,n,k)]<<endl;
        }
      }
      return 0;
    }
  • 相关阅读:
    Java 设计模式——状态模式
    Java 设计模式——外观模式
    Java高级之虚拟机加载机制
    17.1.1.6 Creating a Data Snapshot Using Raw Data Files 创建一个数据快照使用 Raw Data Files
    17.1.1.5 Creating a Data Snapshot Using mysqldump
    17.1.1.4 Obtaining the Replication Master Binary Log Coordinates 得到复制master binary log 位置:
    17.1.1.3 Creating a User for Replication 创建一个用于用于复制:
    17.1.1.2 Setting the Replication Slave Configuration
    17.1.1.1 Setting the Replication Master Configuration 设置复制的master 配置:
    17.1.1 How to Set Up Replication 设置复制:
  • 原文地址:https://www.cnblogs.com/AseanA/p/7156269.html
Copyright © 2011-2022 走看看