zoukankan      html  css  js  c++  java
  • POJ 1469 COURSES


    原来匈牙利是这么写的。。。。。

    Hungary ['h??ɡ?ri] 本地图片,请重新上传

    • n. 匈牙利(欧洲国家名)
     

    COURSES
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 15659Accepted: 6186

    Description

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

    • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
    • each course has a representative in the committee 

    Input

    Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

    P N 
    Count1 Student1 1 Student1 2 ... Student1 Count1 
    Count2 Student2 1 Student2 2 ... Student2 Count2 
    ... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP 

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
    There are no blank lines between consecutive sets of data. Input data are correct. 

    Output

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO

    Source




    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    const int MAXN=555;

    vector<int> g[MAXN];
    bool vis[MAXN];
    int from[MAXN],tot,p,n;

    bool match(int x)
    {
        for(int i=0;i<g[x].size();i++)
        {
            if(!vis[g[x]])
            {
                vis[g[x]]=true;
                if(from[g[x]]==-1||match(from[g[x]]))
                {
                    from[g[x]]=x;
                    return true;
                }
            }
        }
        return false;
    }

    int hungary()
    {
        tot=0;
        memset(from,-1,sizeof(from));
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(match(i)) tot++;
        }
        return tot;
    }

    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&p,&n);
            memset(g,0,sizeof(g));
            for(int i=1;i<=p;i++)
            {
                int m;
                scanf("%d",&m);
                for(int j=1;j<=m;j++)
                {
                    int a;
                    scanf("%d",&a);
                    g.push_back(a);
                }
            }
            if(p==hungary())
                puts("YES");
            else
                puts("NO");
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )
  • 相关阅读:
    iOS 项目中的NSNotification简单使用
    IOS开发之格式化日期时间的使用 && 编程中常见问题
    linker command failed with exit code 1 (use -v to see invocation),经典Xcode编译错误的出现和解决!
    CocoaPods安装和使用教程
    机器学习算法--贝叶斯分类器(二)
    机器学习算法--贝叶斯分类器(一)
    Linux系统初始化过程及运行级别简介
    Linux基本符号
    索引节点inode详解
    Linux文件类型介绍
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350878.html
Copyright © 2011-2022 走看看