zoukankan      html  css  js  c++  java
  • poj3264

                                                                                             Balanced Lineup
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 28628   Accepted: 13468
    Case Time Limit: 2000MS

    Description

    For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

    Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

    Input

    Line 1: Two space-separated integers, N and Q
    Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
    Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

    Output

    Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

    Sample Input

    6 3
    1
    7
    3
    4
    2
    5
    1 5
    4 6
    2 2

    Sample Output

    6
    3
    0

    #include<iostream>
    #include<cmath>
    #include<cstring>
    #include<string>
    #include<cstdio>
    using namespace std;
    int n,dmax[100005][22],dmin[100005][22],a[100005];
    int max(int a,int b)
    {
        return a > b? a:b;
    }
    int min(int a,int b)
    {
        return a<b ? a:b;
    }
    //模板
    void RMQ_init() { int i,j; for(i=1;i<=n;i++) { dmax[i][0] = a[i]; dmin[i][0] = a[i]; } for(j=1;(1<<j)<=n;j++) { for(i=1;i+j-1<=n;i++) { dmin[i][j] = min(dmin[i][j-1],dmin[i+(1<<(j-1))][j-1]); dmax[i][j] = max(dmax[i][j-1],dmax[i+(1<<(j-1))][j-1]); } } } int RMQ(int l,int r) { int k =0 ; while((1<<(k+1))<=r-l+1) k++; int sum1 = max(dmax[l][k],dmax[r-(1<<k)+1][k]); int sum2 = min(dmin[l][k],dmin[r-(1<<k)+1][k]); return sum1 - sum2; }
    //
    int main() { int m,i; while(scanf("%d %d",&n,&m)!=EOF) { int x,y; for(i=1;i<=n;i++) { scanf("%d",&a[i]); } RMQ_init(); for(i=0;i<m;i++) { scanf("%d %d",&x,&y); int sum = RMQ(x,y); printf("%d ",sum); } } return 0; }
  • 相关阅读:
    SDL的视频子系统
    SDL事件处理
    视频子系统中构基本概念和常用数据结
    ASP.NET程序打包的时候如何把TreeView一起打包(转)
    Javascript实现在DataGrid或DataList等容器上的CheckBox全选和取消
    Javascript实现DataGrid或DataList等容器上面选择单选框RadioButton
    git push 报src refspec xxx does not match any的错误
    vue运行报错error:Cannot assign to read only property 'exports' of object '#<Object>'
    weex不支持类的动态追加
    函数的作用域链在定义时已经确定!!
  • 原文地址:https://www.cnblogs.com/Deng1185246160/p/3247531.html
Copyright © 2011-2022 走看看