zoukankan      html  css  js  c++  java
  • POJ2828 Buy Tickets 线段树

    这个题正向建树比较困难,但是反向建树然后树里维护空格的个数就很简单.就是每次插入第几个空格就行了.

    题干:

    Description
    
    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…
    
    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.
    
    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!
    
    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.
    
    Input
    
    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:
    
        Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
        Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
    
    There no blank lines between test cases. Proceed to the end of input.
    
    Output
    
    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.
    
    Sample Input
    
    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492
    Sample Output
    77 33 69 51
    31492 20523 3890 19243
    View Code

    代码:

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<queue>
    #include<stack>
    #include<cmath>
    using namespace std;
    #define duke(i,a,n) for(int i = a;i <= n;i++)
    #define lv(i,a,n) for(int i = a;i >= n;i--)
    #define clean(a) memset(a,0,sizeof(a))
    const int INF = 1 << 30;
    const int mod = 998244353;
    typedef double db;
    template <class T>
    void read(T &x)
    {
        char c;
        bool op = 0;
        while(c = getchar(), c < '0' || c > '9')
            if(c == '-') op = 1;
        x = c - '0';
        while(c = getchar(), c >= '0' && c <= '9')
            {x = x * 10 + c - '0';if(x > mod) x %= mod;}
        if(op) x = -x;
    }
    template <class T>
    void write(T x)
    {
        if(x < 0) putchar('-'), x = -x;
        if(x >= 10) write(x / 10);
        putchar('0' + x % 10);
    }
    struct node
    {
        int val,pos;
    }t[1000040];
    int tree[1000040];
    int a[1000040];
    int n;
    void build(int o,int l,int r)
    {
        if(l == r)
        {
            tree[o] = 1;
            return;
        }
        int mid = (l + r) >> 1;
        build(o << 1,l,mid);
        build(o << 1 | 1,mid + 1,r);
        tree[o] = tree[o << 1] + tree[o << 1 | 1];
    }
    void update(int o,int l,int r,int id,int w)
    {
        if(l == r)
        {
            a[l] = w;
            tree[o] --;
            return;
        }
        int mid = (l + r) >> 1;
        if(tree[o << 1] >= id)
        update(o << 1,l,mid,id,w);
        else
        update(o << 1 | 1,mid + 1,r,id - tree[o << 1],w);
        tree[o] = tree[o << 1] + tree[o << 1 | 1];
    }
    int main()
    {
        while(scanf("%d",&n) != EOF)
        {
            build(1,1,n);
            duke(i,1,n)
            {
                read(t[i].pos);
                t[i].pos ++;
                read(t[i].val);
            }
            lv(i,n,1)
            {
                update(1,1,n,t[i].pos,t[i].val);
            }
            duke(i,1,n)
            {
                printf("%d ",a[i]);
            }
            puts("");
        }
    }
  • 相关阅读:
    1.1 What is the plug-in?
    Chapter 8 The Simplest Plug-in Solution
    Chapter 7 Resources in Plug-In(1)
    Chapter 1: Plug-in programing from past to the future
    Android插件化的兼容性(下):突破Android P中灰黑名单的限制
    Android插件化的兼容性(中):Android P的适配
    Android插件化的兼容性(上):Android O的适配
    pandas 学习 第12篇:DataFrame 避免链式赋值
    NumPy 学习 第三篇:矢量化和广播
    Wait Type 整理
  • 原文地址:https://www.cnblogs.com/DukeLv/p/9790417.html
Copyright © 2011-2022 走看看