zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1084 Broken Keyboard (20分)

    1.题目

    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:

    7_This_is_a_test
    _hs_s_a_es
    

    Sample Output:

    7TI

    2.题目分析

    PAT (Basic Level) Practice 1029 旧键盘 (20分) (string 中的find查找用法)

    3.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<cctype>
    using namespace std;
    int main()
    {
    	string a, b,answer;
    	cin >>a >>b;
    	for (int i = 0; i < a.length(); i++)
    	{
    		if (b.find(a[i]) == string::npos&&answer.find(toupper(a[i]))== string::npos)
    		{
    			answer += toupper(a[i]);
    
    		}
    	}
    	cout << answer;
    
    }
    
  • 相关阅读:
    Easyui 表格底部加合计
    jQuery设置checkbox 为选中状态
    HTML 列表中的dl,dt,dd,ul,li,ol区别
    jQuery的toggle事件
    EasyUI 的日期控件单击文本框显示日历
    HTML设置span宽度
    JQuery获取与设置select
    生命周期
    钩子函数
    组件
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788832.html
Copyright © 2011-2022 走看看