zoukankan      html  css  js  c++  java
  • Argus--[优先队列]

    Description

    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

    For the Argus, we use the following instruction to register a query: 
    Register Q_num Period

    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

    Input

    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

    Output

    You should output the Q_num of the first K queries to return the results, one number per line.

    Sample Input

    Register 2004 200
    Register 2005 300
    #
    5
    

    Sample Output

    2004
    2005
    2004
    2004
    2005

    解题思路:
    假设绝对时间T,容易发现,对每一个query,每当T增加period时就会进行输出。我们不妨这样想,每次输出的query都是离下一次输出需要时间最少的。那么我们就可以采用优先队列存储query,记下一次输出时间为cnt,cnt越小的query优先级越高,每次取队列头元素,输出之后执行cnt+=period,再存入队列。
    注意:
    优先队列默认元素越大优先级越高,因此定义静态成员函数‘<’时按大于号来定义。

    代码如下:
    #include <iostream>
    #include <time.h>
    #include <queue>
    #include <vector>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    #define _clock (double(clock())/CLOCKS_PER_SEC)
    
    using namespace std;
    
    char buff[30];
    
    struct query{
        int Q_num;
        int Period;
        int cnt;
        query(int q=0,int p=0):Q_num(q),Period(p){cnt=Period;}
        bool operator <(const query& a)const {
            return (cnt>a.cnt)||((cnt==a.cnt)&&Q_num>a.Q_num);
        }
    };
    
    priority_queue<query> u;
    int q,p,k;
    
    int main(){
        while(scanf("%s",buff)==1&&buff[0]!='#'){
            scanf("%d%d",&q,&p);
            u.push(query(q,p));
        }
        scanf("%d",&k);
        while(k--){
            query a=u.top();u.pop();
            cout<<a.Q_num<<endl;
            a.cnt+=a.Period;
            u.push(a);
        }
        //cout<<"time : "<<_clock<<endl;
        return 0;
    }
     
  • 相关阅读:
    my97date与struts2的结合使用
    window.frames["detailFrm"].isSubmitting = true;//?起什么作用
    apache ant
    JodaTime 简介
    dbgrid中没有数据原因1
    网页 BODY的topMargin 和leftMargin
    在java类中定义log
    discuz论坛移动后,如果不能连接上数据库。可能是连接数据库的用户密码不正确。
    在后台对字符串进行转码
    [转] 我们的企业比日本少了什么
  • 原文地址:https://www.cnblogs.com/Kiraa/p/5279496.html
Copyright © 2011-2022 走看看