zoukankan      html  css  js  c++  java
  • 九度OnlineJudge之1036:Old Bill

    题目描述:

        Among grandfather's papers a bill was found.
        72 turkeys $_679_
        The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?
        We want to write a program that solves a general version of the above problem.
        N turkeys $_XYZ_
        The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an integer number of dollars, and that all the
    turkeys cost the same price.
        Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

    输入:

        The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

    输出:

        For each case, output the two faded digits and the maximum price per turkey for the turkeys.

    样例输入:
    72
    6 7 9
    5
    2 3 7
    78
    0 0 5
    样例输出:
    3 2 511
    9 5 18475
    0
    #include<iostream>
    
    using namespace std;
    
    int main()
    {
    	int n,x,y,z,i,j,t;
    	while(cin>>n>>x>>y>>z)
    	{
    		bool flag = false;
    
    		int tmp = 1000*x+100*y+10*z;
    		for ( i=9;i>0;i--)
    		{
    			for ( j=9;j>=0;j--)
    			{
    				t = tmp + i*10000 +j;
    				if (t%n==0) {flag = true;break;}	  
    			}
    			if (flag)  break;
    		}
    		if (flag)
    		cout<<i<<" "<<j<<" "<<t/n<<endl;
    		else
    		cout<<"0"<<endl;
    		
    	}
    
    	//system("pause");
    	return 0;
    }


  • 相关阅读:
    centos7使用163 yum源
    Package has no installation candidate解决方法
    HTML 5 canvas相关
    git rebase 使用总结
    Redis不是只有get set那么简单
    k8s---pod常用操作
    Navigator.sendBeacon 无阻塞发送统计数据
    如何在页面关闭或跳转时优雅的发送Ajax请求
    mysql的触发器、视图、索引,受益匪浅
    杂集:centos7中利用logrotate工具切割tomcat日志
  • 原文地址:https://www.cnblogs.com/ainima/p/6331209.html
Copyright © 2011-2022 走看看