zoukankan      html  css  js  c++  java
  • 洛谷 P2419 [USACO08JAN]牛大赛Cow Contest

    题目背景

    [Usaco2008 Jan]

    题目描述

    N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

    The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

    Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

    FJ的N(1 <= N <= 100)头奶牛们最近参加了场程序设计竞赛:)。在赛场上,奶牛们按1..N依次编号。每头奶牛的编程能力不尽相同,并且没有哪两头奶牛的水平不相上下,也就是说,奶牛们的编程能力有明确的排名。 整个比赛被分成了若干轮,每一轮是两头指定编号的奶牛的对决。如果编号为A的奶牛的编程能力强于编号为B的奶牛(1 <= A <= N; 1 <= B <= N; A != B) ,那么她们的对决中,编号为A的奶牛总是能胜出。 FJ想知道奶牛们编程能力的具体排名,于是他找来了奶牛们所有 M(1 <= M <= 4,500)轮比赛的结果,希望你能根据这些信息,推断出尽可能多的奶牛的编程能力排名。比赛结果保证不会自相矛盾。

    输入输出格式

    输入格式:

     

    第1行: 2个用空格隔开的整数:N 和 M

    第2..M+1行: 每行为2个用空格隔开的整数A、B,描述了参加某一轮比赛的奶 牛的编号,以及结果(编号为A,即为每行的第一个数的奶牛为 胜者)

     

    输出格式:

     

    第1行: 输出1个整数,表示排名可以确定的奶牛的数目

     

    输入输出样例

    输入样例#1:
    5 5
    4 3
    4 2
    3 2
    1 2
    2 5
    输出样例#1:
    2
    

    说明

    输出说明:

    编号为2的奶牛输给了编号为1、3、4的奶牛,也就是说她的水平比这3头奶

    牛都差。而编号为5的奶牛又输在了她的手下,也就是说,她的水平比编号为5的

    奶牛强一些。于是,编号为2的奶牛的排名必然为第4,编号为5的奶牛的水平必

    然最差。其他3头奶牛的排名仍无法确定。

    思路:floyd:g[i][j]表示i胜过j,若g[i][k]&&g[k][j],则g[i][j]。所以跑floyd判断一下。

    #include<cstdio>
    #include<iostream>
    using namespace std;
    int g[101][101];
    int n,m,ans;
    int main(){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            g[x][y]=1;
        }    
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    g[i][j]=g[i][k]&g[k][j]|g[i][j];
        for(int i=1;i<=n;i++){
            int f=1;
            for(int j=1;j<=n;j++)
                if(i!=j)
                    f=f&g[i][j]|g[j][i];
            ans+=f;
        }
        printf("%d",ans);
        return 0;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    如何解决MySQL Workbench Error Code 2013报错问题
    如何解决 执行 delete from 表等 遇到Mysql Workbench的Error Code: 1175错误
    java猜数字游戏while循环
    HDU 1069
    dp入门 石子相邻合并 详细带图讲解
    阶乘 大数保存
    strlen实现
    01背包和完全背包
    1.23 codeforces div3 C.Nice Garland
    数字三角形
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7419095.html
Copyright © 2011-2022 走看看