zoukankan      html  css  js  c++  java
  • HDU:Who's in the Middle

    Who's in the Middle

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1520 Accepted Submission(s): 586

    Problem Description
    FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

    Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
     

    Input
    * Line 1: A single integer N

    * Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
     

    Output
    * Line 1: A single integer that is the median milk output.
     

    Sample Input
    5
    2
    4
    1
    3
    5
     

    Sample Output
    3
    Hint
    INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
     

     
    Source
    USACO 2004 November
     

    Recommend
    mcqsmall

    一个简单的快速排序,然后找一下中间值。

    #include<iostream>
    using namespace std;
    int list[10001];
    void quicksort(int i,int j)
    {
        if(i<j)
        {
            int f,l,sym;
            f=i;
            l=j;
            sym=list[i]; //基准
            while(i<j)
            {
                while(i<j&&list[j]>=sym)
                    j--;
                if(i<j)
                    list[i++]=list[j];
                while(i<j&&list[i]<sym)
                    i++;
                if(i<j)
                    list[j--]=list[i];
            }
            list[i]=sym;
            quicksort(f,i-1);
            quicksort(i+1,l);
        }
    }
    int main()
    {
        int n,i;
        while(cin>>n)
        {
            for(i=1;i<=n;i++)
                cin>>list[i];
            quicksort(1,n);
            cout<<list[(n+1)/2]<<endl;
        }
        return 0;
    }

  • 相关阅读:
    模式对象管理
    Oracle数据库实例
    github使用简介
    Oracle数据库安装与连接与简介
    利益相关者分析
    问题账户需求分析
    2018春季学期需求工程概论阅读计划
    JAXB在Java 9/10并且使用Tomcat 9的问题
    mysql 备份 恢复
    IntelliJ IDEA安装bower
  • 原文地址:https://www.cnblogs.com/connorzx/p/2642461.html
Copyright © 2011-2022 走看看