zoukankan      html  css  js  c++  java
  • UVa 111 History Grading 最长递增子序列 LIS



     History Grading 

    Background

    Many problems in Computer Science involve maximizing some measure according to constraints.

    Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

    Some possibilities for partial credit include:

    1. 1 point for each event whose rank matches its correct rank
    2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

    For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

    In this problem you are asked to write a program to score such questions using the second method.

    The Problem

    Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 wheretex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

    The Input

    The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

    The Output

    For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

    Sample Input 1

    4
    4 2 3 1
    1 3 2 4
    3 2 1 4
    2 3 4 1

    Sample Output 1

    1
    2
    3

    Sample Input 2

    10
    3 1 2 4 9 5 10 6 8 7
    1 2 3 4 5 6 7 8 9 10
    4 7 2 3 10 6 9 1 5 8
    3 1 2 4 9 5 10 6 8 7
    2 10 1 3 8 4 9 5 7 6
    

    Sample Output 2

    6
    5
    10
    9
    -------------------------------------------------------

    本来是一道很简单的LIS,但是输入太坑爹了,输入序列表示历史事件发生在第几位,而我们需要记录的是第i位发生了第几个历史事件。。。

    对输入进行转化,c[i]表示第i个事件应该第几位发生,记录输入的数组即可。

    a[i]表示学生的答案第i位发生的哪一个事件。而数据输入的是第i个历史事件发生在第几位。因此需要读入的数据t、a[t]=c[i];

    -------------------------------------------------------


    #include <iostream>
    #include <cstring>
    #include <cstdio>
    
    using namespace std;
    
    const int maxn=1111;
    int a[maxn];
    int c[maxn];
    int f[maxn];
    int ans;
    int n;
    
    int main()
    {
        int t;
        scanf("%d",&n);
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&t);
            c[i]=t;
        }
        while (~scanf("%d",&t))
        {
            memset(a,0,sizeof(a));
            memset(f,0,sizeof(f));
            a[t]=c[1];
            for (int i=2;i<=n;i++)
            {
                scanf("%d",&t);
                a[t]=c[i];
            }
            ans=0;
            for (int i=1;i<=n;i++)
            {
                for (int k=0;k<i;k++)
                {
                    if (a[i]>a[k]) f[i]=max( f[i], f[k]+1 );
                }
                ans=max(ans,f[i]);
            }
            printf("%d\n",ans);
        }
        return 0;
    }
    







     History Grading 

    Background

    Many problems in Computer Science involve maximizing some measure according to constraints.

    Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

    Some possibilities for partial credit include:

    1. 1 point for each event whose rank matches its correct rank
    2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

    For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

    In this problem you are asked to write a program to score such questions using the second method.

    The Problem

    Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 wheretex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

    The Input

    The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

    The Output

    For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

    Sample Input 1

    4
    4 2 3 1
    1 3 2 4
    3 2 1 4
    2 3 4 1

    Sample Output 1

    1
    2
    3

    Sample Input 2

    10
    3 1 2 4 9 5 10 6 8 7
    1 2 3 4 5 6 7 8 9 10
    4 7 2 3 10 6 9 1 5 8
    3 1 2 4 9 5 10 6 8 7
    2 10 1 3 8 4 9 5 7 6
    

    Sample Output 2

    6
    5
    10
    9
  • 相关阅读:
    MYSQL数据库导入SQL文件出现乱码解决方法
    Mysql设置允许用户可以连接
    MongoDB 设置权限认证
    NodeJs 服务端调试
    Hudson 定时编译
    Ubuntu上NodeJs环境安装
    新开通博客
    war类型项目创建
    Maven项目创建
    Maven简介与配置
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038372.html
Copyright © 2011-2022 走看看