zoukankan      html  css  js  c++  java
  • POJ 1159 Palindrome

    Palindrome
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 51518   Accepted: 17733

    Description

    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

    Input

    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

    Output

    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

    Sample Input

    5
    Ab3bd

    Sample Output

    2


    简单的 区间动规,主要是easyMLE。


    AC代码例如以下:

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    char a[5005];
    short dp[5005][5005];//用short就能够不MLE了
    int min(int a,int b)
    {
        return a<b?a:b;
    }
    
    int main()
    {
        int n;
        int ans;
        int i,j;
        while(cin>>n)
        {
            memset(dp,0,sizeof dp);
            cin>>a+1;
            //cout<<a+1;
            for(i=1;i<=n;i++)
            {
                dp[i][i]=0;//i==j时不用补字母
            }
            int len;
            for(len=2;len<=n;len++)
            {
                for(i=1;i<=n-len+1;i++)
                {
                    j=i+len-1;
                    if(a[i]==a[j])//此时[i,j]须要补字母数等于[i+1,j-1]中所需补的字母
                        dp[i][j]=dp[i+1][j-1];
                    else
                    {
                        dp[i][j]=min(dp[i][j-1],dp[i+1][j])+1;//此时须要找两个缩小区间的最小值
                    }
    
                }
            }
            cout<<dp[1][n]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    C++ 引用做左值
    C++ 引用本质的详解
    C++ 引用基础
    C语言错误 指针的类型错误
    C++ c++与C语言的区别(三目运算符,const修饰符)
    C++ c++与C语言的区别(struct类型的加强,函数-变量类型加强,bool类型)
    C++ c++与C语言的区别(实用性增强,register关键字增强,全局变量检测增强)
    C++ c++初识
    C语言 Linux内核链表(企业级链表)
    C语言 结构体中属性的偏移量计算
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/7009029.html
Copyright © 2011-2022 走看看