7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
- 输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
- 输出
- Your program is to write to standard output. The highest sum is written as an integer.
- 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
- 样例输出
-
30
/* 明确动态转移方程 f[i][j]=max(f[i+1][j],f[i+1][j+1])+a[i][j]
基础的dp 注意不是一组测试数据 */
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[105][105];
int n;
int f[105][105];
int dp(int i,int j)
{
int r;
if(f[i][j]!=0)return f[i][j];
if(i==n-1)
{
f[i][j]=a[i][j];
return f[i][j];
}
else
{
f[i][j]=dp(i+1,j);
f[i+1][j+1]=dp(i+1,j+1);
r=f[i][j]>f[i+1][j+1]?f[i][j]:f[i+1][j+1];
r=r+a[i][j];
return r;
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(f,0,sizeof(f));
int i,j;
for(i=0;i<n;i++)
for(j=0;j<=i;j++)
scanf("%d",&a[i][j]);
cout<<dp(0,0)<<endl;
}
return 0;
}