zoukankan      html  css  js  c++  java
  • hdu 1250 Hat's Fibonacci

    http://acm.hdu.edu.cn/showproblem.php?pid=1250

    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3943    Accepted Submission(s): 1346

    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     
    Author
    戴帽子的
     
    Recommend
    Ignatius.L
     
    自己写的不怎么样,用了500+MS  不过看到了一个牛B的代码,还是保存下来,有时间慢慢研究。
    我的代码:
    #include <stdio.h>
    #include <string.h>
    #define MAX 3000+3
    
    char str1[MAX],str2[MAX],c[MAX];
    
    void jia(char str1[],char str2[],char sum[])
    {
        int i,j,k,z;
        z=0;
        k=0;
        for(i=strlen(str1)-1,j=strlen(str2)-1;i>=0||j>=0;i--,j--)
        {
            if(i>=0)
                z+=str1[i]-'0';
            if(j>=0)
                z+=str2[j]-'0';
            c[k++]=z%10+'0';
            z/=10;
        }
        if(z) c[k++]='1';
        i=0;
        for(--k;k>=0;k--)
            sum[i++]=c[k];
        sum[i]='\0';
    }
    
    int main()
    {
    
        int i,n;
        //char str1[MAX]="0",str2[MAX]="1",f[MAX];
        while(scanf("%d",&n)==1)
        {
            char str1[MAX]="1",str2[MAX]="1",str3[MAX]="1",str4[MAX]="1",f[MAX],f1[MAX],sum[MAX];
            if(n==0)
            {
                printf("0\n");
                continue;
            }
            for(i=4;i<n;i++)
            {
                jia(str1,str2,f);
                jia(str3,str4,f1);
                jia(f,f1,sum);
                strcpy(str1,str2);
                strcpy(str2,str3);
                strcpy(str3,str4);
                strcpy(str4,sum);
            }
            printf("%s\n",str4);
        }
        return 0;
    }

    http://www.cnblogs.com/newpanderking/archive/2011/07/31/2122528.html

    用二维数组模拟大数加法,每一行表述一个数,每一行的一个元素可以代表n位数,这个可以根据自己的需要自己定义。
    其他的就和正常的加法一样了,注意进位处理。

    代码:

    #include <iostream>
    #include <stdio.h>
    using namespace std;
    int s[7500][670];
    void solve(){
        s[1][1] = 1;s[2][1] = 1;
        s[3][1] = 1;s[4][1] = 1;
        int i,j,k=0;
        for(i = 5;i<7500;i++)
        for( j = 1;j<=670 ;j++)
        {
            k += s[i-1][j]+s[i-2][j]+s[i-3][j]+s[i-4][j];
            s[i][j] = k%10000;
            k = k/10000;
        }
        while(k)
        {
            s[i][j++] = k%10000;
            k = k/10000;
        }
    }
    int main()
    {
        int n,i,j;
        solve();
        while(cin>>n)
        {
            for(i = 670; i>=1;i--)
            if(s[n][i]!=0)break;
            printf("%d",s[n][i]);
            for(j = i-1;j>=1;j--)
            printf("%04d",s[n][j]);
            printf("\n");
        }
    }
  • 相关阅读:
    Django学习笔记之中间件和上下文处理器
    python练手小题(四)
    python练手小题(三)
    python练手小题(二)
    python练手小题(一)
    Django学习笔记之自定义过滤器及标签
    Django学习笔记之模板标签与静态文件
    Django学习笔记之模板变量与模板过滤器
    Django学习笔记之url路由及模板渲染方式
    学习Go语言的9大理由
  • 原文地址:https://www.cnblogs.com/hzg656343072/p/2646492.html
Copyright © 2011-2022 走看看