zoukankan      html  css  js  c++  java
  • Maximum Subsequence Sum(接上篇)

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    Sample Output:
    10 1 4

     总之和上面一篇几乎一样,有几点小坑注意一下就好了:

    1:If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    2.The numbers must be separated by one space, but there must be no extra space at the end of a line. 

    3.最后一点没提到,也就是我一直不能AC的原因:

      当sequence中 全是非正数的情况,并不能归纳到 1 中,举个例子:sequence : -1 -2 -3  0 -5 

                                    out:0 0 0 而不是 0 -1 -5

    code:

    #include <iostream>
    #include <vector>
    using namespace std;
    
    int SubSum(vector<int>& v,int& m,int& n,bool& find){
        int MaxSum = 0,tmp = 0,tmp_m = v[0];//先移动tmp_m
        m = n = v[0];//当sequence比当前大再把m移到tmp_m处
        for(int i=0;i<v.size();++i){
            tmp += v[i];
            if(tmp > MaxSum){
                find = true;
                int tmp_max = MaxSum;//tm_max用来判断是否移动n
                MaxSum = tmp;
                m =tmp_m;
                if(MaxSum > tmp_max)
                    n = v[i];
            }
            else if(tmp < 0){
                tmp = 0;
                tmp_m = v[i+1];
            }
        }
        int max = v[0];
        for(int i=0;i<v.size();++i)
            if(v[i]>max){
                max =v[i];
                find = true;
            }
        if(max == 0)
            m = n =0;
        return MaxSum;
    }
    
    int main()
    {
        int n,tmp,start,end;
        bool find =false;//是否存在最大子队列
        vector<int> v;
        cin >> n;
        for(int i=0;i<n;++i){
            cin >> tmp;
            v.push_back(tmp);
        }
        n = SubSum(v,start,end,find);
        if(find)
            cout << n << ' ' << start << ' ' << end << endl;
        else
            cout << n << ' ' << v.front() << ' ' << v.back() << endl;
        return 0;
    }
       
  • 相关阅读:
    Day 9
    Day 8
    Day 7
    Day 6
    Day 5
    Day 4
    Day 3
    Day 2
    Day 1
    解决vue-cli3不停请求 /sockjs-node/info?t= 问题
  • 原文地址:https://www.cnblogs.com/ittinybird/p/4141275.html
Copyright © 2011-2022 走看看