zoukankan      html  css  js  c++  java
  • POJ2225:Asteroids!(BFS) java程序员

    Asteroids!
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 2653   Accepted: 1006

    Description

    You're in space. 
    You want to get home. 
    There are asteroids. 
    You don't want to hit them.

    Input

    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

    A single data set has 5 components: 
    1. Start line - A single line, "START N", where 1 <= N <= 10. 
    2. Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values: 
        'O' - (the letter "oh") Empty space 
        'X' - (upper-case) Asteroid present

    3. Starting Position - A single line, "A B C", denoting the [A,B,C] coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces. 
    4. Target Position - A single line, "D E F", denoting the [D,E,F] coordinates of your target's position. The coordinate values will be integers separated by individual spaces. 
    5. End line - A single line, "END"

    The origin of the coordinate system is [0,0,0]. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive. 

    The first coordinate in a set indicates the column. Left column = 0. 
    The second coordinate in a set indicates the row. Top row = 0. 
    The third coordinate in a set indicates the slice. First slice = 0. 

    Both the Starting Position and the Target Position will be in empty space. 

    Output

    For each data set, there will be exactly one output set, and there will be no blank lines separating output sets. 

    A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead. 

    A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1. 

    Sample Input

    START 1
    O
    0 0 0
    0 0 0
    END
    START 3
    XXX
    XXX
    XXX
    OOO
    OOO
    OOO
    XXX
    XXX
    XXX
    0 0 1
    2 2 1
    END
    START 5
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    0 0 0
    4 4 4
    END
    

    Sample Output

    1 0
    3 4
    NO ROUTE
    

    Source

    MCYode:

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<queue>
    using namespace std;
    int step[11][11][11];
    #define inf 10000000
    int n;
    struct node
    {
        int x,y,z;
        int step;
    };
    int dirt[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
    char mat[11][11][11];
    char tp[20];
    node bg,ed;
    bool reach;
    void init()
    {
        int i,j,k;
        for(k=0;k<n;k++)
        {
            for(i=0;i<n;i++)
            {
                for(j=0;j<n;j++)
                {
                    step[i][j][k]=inf;
                }
            }
        }
    }
    int bfs()
    {
        queue<node> q;
        step[bg.x][bg.y][bg.z]=0;
        bg.step=0;
        q.push(bg);
        while(!q.empty())
        {
            node p=q.front();
            if(p.x==ed.x&&p.y==ed.y&&p.z==ed.z)
            {
                return p.step;
            }
            q.pop();
            //cout<<"move to"<<p.x<<" "<<p.y<<" "<<p.z<<endl;
            node tp;
            int i;
            for(i=0;i<6;i++)
            {
                tp=p;
                tp.x+=dirt[i][0];
                tp.y+=dirt[i][1];
                tp.z+=dirt[i][2];
                //cout<<tp.x<<"*"<<tp.y<<"*"<<tp.z<<endl;
                tp.step++;
                //cout<<"show "<<step[tp.x][tp.y][tp.z]<<" "<<tp.step<<endl;
                if(mat[tp.x][tp.y][tp.z]=='O'&&
                tp.x>=0&&tp.x<n&&tp.y>=0&&tp.y<n&&tp.z>=0&&tp.z<n
                &&step[tp.x][tp.y][tp.z]>tp.step)
                {
                    //cout<<"push"<<endl;
                    step[tp.x][tp.y][tp.z]=tp.step;
                    q.push(tp);
                }
            }
        }
        return -1;
    }


    int main()
    {
        while(scanf("%s",&tp)!=EOF)
        {
            scanf("%d",&n);
            int i,j,k;
            for(k=0;k<n;k++)
            {
                for(i=0;i<n;i++)
                {
                    for(j=0;j<n;j++)
                    {
                        cin>>mat[i][j][k];
                    }
                }
            }
            /*for(k=0;k<n;k++)
            {
                for(i=0;i<n;i++)
                {
                    for(j=0;j<n;j++)
                    {
                        cout<<mat[i][j][k];
                    }
                    cout<<endl;
                }
                cout<<endl;
            }*/
            scanf("%d%d%d",&bg.y,&bg.x,&bg.z);
            scanf("%d%d%d",&ed.y,&ed.x,&ed.z);
            scanf("%s",&tp);
            init();
            int ans=bfs();
            if(ans!=-1)
            {
                printf("%d %d\n",n,ans);
            }
            else
            printf("NO ROUTE\n");
        }
    }

    //

    BFS,三维空间的搜索. 

  • 相关阅读:
    SQL逻辑查询处理阶段
    将json字符串转换为json兑现
    JSTL核心标签库
    eclipse用4个空格代替Tab 每行80字符限制提示线显示空格
    MyEclipse8.6 性能优化
    jsp/servlet总结复习
    SQLServer之MERGE INTO
    as3效率提升
    让默认TextField更清晰地显示中文
    as3垃圾回收机制
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215884.html
Copyright © 2011-2022 走看看