zoukankan      html  css  js  c++  java
  • C Looooops(扩展欧几里得)

    C Looooops
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 20128 Accepted: 5405

    Description
    A Compiler Mystery: We are given a C-language style for loop of type

    for (variable = A; variable != B; variable += C)

    statement;

    I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

    Input
    The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

    The input is finished by a line containing four zeros.

    Output
    The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

    Sample Input

    3 3 2 16
    3 7 2 16
    7 3 2 16
    3 4 2 16
    0 0 0 0

    Sample Output

    0
    2
    32766
    FOREVER

    Source
    CTU Open 2004

    看了题解还是不太懂,有时间去请教一下大神

    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <string>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    #define PI cos(-1.0)
    #define RR freopen("input.txt","r",stdin)
    
    using namespace std;
    
    typedef long long LL;
    
    LL ExtendedEuclid(LL a,LL b,LL &x,LL &y)
    {
        if(b==0)
        {
            x=1;
            y=0;
            return a;
        }
        LL d=ExtendedEuclid(b,a%b,x,y);
        LL xt=x;
        x=y;
        y=xt-a/b*y;
        return d;
    }
    
    int main()
    {
        LL A,B,C,K;
        while(cin>>A>>B>>C>>K)
        {
            if(!A&&!B&&!C&&!K)
            {
                break;
            }
            LL a=C;
            LL b=B-A;
            LL n=(LL)1<<K;
            LL x,y;
            LL d=ExtendedEuclid(a,n,x,y);
            if(b%d!=0)
            {
                cout<<"FOREVER"<<endl;
            }
            else
            {
                x=(x*(b/d))%n;
                x=(x%(n/d)+n/d)%(n/d);
                cout<<x<<endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    02_java基础学习_基础语法(上)01_day02总结
    EditPlus如何设置保存时不产生.bak备份文件?
    UltraEdit(UE)如何设置去掉.bak备份文件?
    如何在win10上连接苹果无线键盘
    01_java基础学习_Java概述_day01总结
    Python 提取Twitter tweets中的元素(包括text, screen names, hashtags)
    #leetcode#Path Sum II
    怎样实现广度优先遍历(BFS)
    GCD编程-串行队列与并发队列
    在对方电脑建立IPC连接, 利用IPC$入侵 运行木马
  • 原文地址:https://www.cnblogs.com/juechen/p/5255951.html
Copyright © 2011-2022 走看看