zoukankan      html  css  js  c++  java
  • UVA

      Tree Recovery 

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

    This is an example of one of her creations:

                                        D
                                       / 
                                      /   
                                     B     E
                                    /      
                                   /         
                                  A     C     G
                                             /
                                            /
                                           F
    

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

    For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

    However, doing the reconstruction by hand, soon turned out to be tedious.

    So now she asks you to write a program that does the job for her!

    Input Specification 

    The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

    Input is terminated by end of file.

    Output Specification 

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input 

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output 

    ACBFGED
    CDAB
    
    
    
    
    二叉树+BFS题目,略水
    #include <iostream>
    #include <cstring>
    #include <vector>
    #include <string>
    #include <algorithm>
    #define MAXN 256
    using namespace std;
    
    string PreOrder, InOrder;
    vector<char> PostOrder;
    char Lch[MAXN], Rch[MAXN];
    int Build_tree(int L1, int R1, int L2, int R2)
    {
    	if (L2 > R2)
    		return false;
    	char root = PreOrder[L1];
    	int p = L2;
    	while (root != InOrder[p])
    		p++;
    	int cnt = p - L2;
    	Lch[root] = Build_tree(L1 + 1, L1 + cnt, L2, L2 + cnt - 1);
    	Rch[root] = Build_tree(L1 + cnt + 1, R1, L2 + cnt + 1, R2);
    	return root;
    }
    
    void dfs(int n)
    {
    	if (Lch[n]) dfs(Lch[n]);
    	if (Rch[n]) dfs(Rch[n]);
    	PostOrder.push_back(n);
    }
    
    int main()
    {
    	while (cin >> PreOrder >> InOrder)
    	{
    		memset(Lch, 0, sizeof(Lch));
    		memset(Rch, 0, sizeof(Rch));
    		char root = Build_tree(0, PreOrder.length() - 1, 0, InOrder.length() - 1);
    		PostOrder.clear();
    		dfs(root);
    		for (size_t i = 0; i < PostOrder.size(); i++)
    			cout << PostOrder[i];
    		cout << endl;
    	}
    	return 0;
    }
    


  • 相关阅读:
    Android 数据库SQLite的使用简单Demo
    jQuery插件FullCalendar日程表
    Activiti工作流访问路径资源注册和管理
    电子商务中的数据仓库技术
    打开”我的电脑”慢的解决办法
    数据结构定义中的中(大陆地区)美差异
    Wubi离线安装Ubuntu
    C++如何获得U盘的盘符以及U盘相关属性的代码
    浮动引起的文本重影
    定位相关的怪异问题
  • 原文地址:https://www.cnblogs.com/kunsoft/p/5312777.html
Copyright © 2011-2022 走看看