zoukankan      html  css  js  c++  java
  • UVaOJ 1368

    epsfbox{p3602.eps}

    Figure 1.
    DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:


    ``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"


    Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.


      DNA sequence of gene X
    Cat: GCATATGGCTGTGCA
    Dog: GCAAATGGCTGTGCA
    Horse: GCTAATGGGTGTCCA
    Cow: GCAAATGGCTGTGCA
    Monkey: GCAAATCGGTGAGCA


    Figure 2. DNA sequences of gene X in five animals.


    Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S . For example, given the three strings ``AGCAT" ``AGACT" and ``GGAAT" the consensus string of the given strings is ``AGAAT" because the sum of the Hamming distances between ``AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is ``GCAAATGGCTGTGCA" and the consensus error is 7.

    Input 

    Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers m and n which are separated by a single space. The integer m (4$ le$m$ le$50) represents the number of DNA sequences and n (4$ le$n$ le$1000) represents the length of the DNA sequences, respectively. In each of the next m lines, each DNA sequence is given.

    Output 

    Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases.

    Sample Input 

    3 
    5 8 
    TATGATAC 
    TAAGCTAC 
    AAAGATCC 
    TGAGATAC 
    TAAGATGT 
    4 10 
    ACGTACGTAC 
    CCGTACGTAG 
    GCGTACGTAT 
    TCGTACGTAA 
    6 10 
    ATGTTACCAT 
    AAGTTACGAT 
    AACAAAGCAA 
    AAGTTACCTT 
    AAGTTACCAA 
    TACTTACCAA
    

    Sample Output 

    TAAGATAC 
    7 
    ACGTACGTAA 
    6 
    AAGTTACCAA 
    12



    #include <stdio.h>
    #include <math.h>
    #include <string.h>
    
    char num[55][1005];
    int count[1005][4];
    int main()
    {
        int time;
        scanf("%d",&time);
        while(time--)
        {
            int m,n,i,j;
            scanf("%d %d",&m,&n);
            getchar();
            for(i=0; i<m; i++)
                for(j=0; j<n+1; j++)
                    num[i][j] = getchar();
    
            memset(count,0,sizeof(count));
            for(i=0; i<m; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(num[i][j]=='A')
                        count[j][0]++;
                    if(num[i][j]=='C')
                        count[j][1]++;
                    if(num[i][j]=='G')
                        count[j][2]++;
                    if(num[i][j]=='T')
                        count[j][3]++;
                }
            }
    
            int k,hamming = 0;
            for(i=0; i<n; i++)
            {
                int ok;
                int result;
                result = 0;
                ok = count[i][0];
                for(j=1; j<4; j++)
                {
                    if(count[i][j]>ok)
                    {
                        ok = count[i][j];
                        result = j;
                    }
                }
    
                if(result == 0)
                {
                    printf("A");
                    for(k=0; k<m; k++)
                        hamming += ('A'==num[k][i] ? 0:1);
                }
                else if(result == 1)
                {
                    printf("C");
                    for(k=0; k<m; k++)
                        hamming += ('C'==num[k][i] ? 0:1);
                }
                else if(result == 2)
                {
                    printf("G");
                    for(k=0; k<m; k++)
                        hamming += ('G'==num[k][i] ? 0:1);
                }
    
                else if(result == 3)
                {
                    printf("T");
                    for(k=0; k<m; k++)
                        hamming += ('T'==num[k][i] ? 0:1);
                }
    
            }
                printf("
    %d
    ",hamming);
        }
        return 0;
    }
    


  • 相关阅读:
    StatusStrip控件中元素右对齐方法两则
    在EF4.0中获取ObjectContext的数据库连接字符串
    通过反射调用泛型参数方法
    阻止保存要求重新创建表的更改
    [转]表达式解析的全部源码
    让ADO.NET SelfTracking Entity Generator产生的实体类支持RejectChanges()方法
    关于XtraGrid的CustomUnboundColumnData事件的触发条件
    WCF远程服务器强制关闭了一个连接
    让Sandcastle Help File Builder支持VS2010
    ==Entity Framework DBContext 增删改查深度解析
  • 原文地址:https://www.cnblogs.com/kunsoft/p/5312810.html
Copyright © 2011-2022 走看看