zoukankan      html  css  js  c++  java
  • 食物链(并查集)

    Description

    动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
    现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
    有人用两种说法对这N个动物所构成的食物链关系进行描述: 
    第一种说法是"1 X Y",表示X和Y是同类。 
    第二种说法是"2 X Y",表示X吃Y。 
    此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
    1) 当前的话与前面的某些真的话冲突,就是假话; 
    2) 当前的话中X或Y比N大,就是假话; 
    3) 当前的话表示X吃X,就是假话。 
    你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

    Input

    第一行是两个整数N和K,以一个空格分隔。 
    以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
    若D=1,则表示X和Y是同类。 
    若D=2,则表示X吃Y。

    Output

    只有一个整数,表示假话的数目。

    Sample Input

    100 7
    1 101 1 
    2 1 2
    2 2 3 
    2 3 3 
    1 1 3 
    2 3 1 
    1 5 5
    

    Sample Output

    3

    /*
     * 所以设出来的并查集有三个根,这三个是划分块,不能同时成立,
     * 每个划分块里面是等价类,一个成立则其他都成立 
     */
    import java.util.Scanner;
    
    public class shiwulian {
        private static int N, K;
        private static final int MAX_K = 100001;
        private static final int MAX_N = 50001;
        private static int[] T = new int[MAX_K];
        private static int[] X = new int[MAX_K];
        private static int[] Y = new int[MAX_K];
        private static int[] parent = new int[MAX_N];
        private static int[] height = new int[MAX_N];
    
        public static void main(String[] args) {
            Scanner cin = new Scanner(System.in);
            N = cin.nextInt();
            K = cin.nextInt();
            for (int i = 1; i <= K; ++i) {
                T[i] = cin.nextInt();
                X[i] = cin.nextInt();
                Y[i] = cin.nextInt();
            }
            cin.close();
            solve();
        }
    
        public static void init(int n) {
            for (int i = 1; i <= n; ++i) {
                parent[i] = i;
                height[i] = 1;
            }
        }
    
        public static int find(int p) { // 查找根节点
            int root = p;
            while (root != parent[root]) {// 到这里为加权quick-union算法,往下继续优化
                root = parent[root];
            }
            while (p != root) {// 直接把查找过的结点直接连到根节点,路径压缩
                int newp = parent[p];
                parent[p] = root;
                p = newp;
            }
            return root;
        }
    
        public static boolean same(int x, int y) {
            return find(x) == find(y);
        }
    
        public static void unite(int x, int y) {
            if (x == y)
                return;
            if (height[x] < height[y]) {
                parent[x] = y;
                height[y] += height[x];
            } else {
                parent[y] = x;
                height[x] += height[y];
            }
        }
    
        public static void solve() {
            init(N * 3);
            int ans = 0;
            for (int i = 1; i <= K; ++i) {
                int t = T[i];
                int x = X[i], y = Y[i];
    
                if (x < 1 || x > N || y < 1 || x > N) {
                    ++ans;
                    continue;
                }
    
                if (t == 1) { // 同类
                    if (same(x, y + N) || same(x, y + 2 * N)) {
                        ++ans;
                        continue;
                    } else { // 把ABC类的xy都连在一起
                        unite(x, y);
                        unite(x + N, y + N);
                        unite(x + 2 * N, y + 2 * N);
                    }
                } else if (t == 2) {
                    if (same(x, y) || same(x, y + 2 * N)) {
                        ++ans;
                        continue;
                    } else {
                        unite(x, y + N); // x吃y,y是B类
                        unite(x + N, y + 2 * N); // x吃y,x是B类,y是C类
                        unite(x + 2 * N, y); // x吃y,x是C类,y是A类
                    }
                }
            }
            System.out.println(ans);
        }
    }

    ========================================Talk is cheap, show me the code=======================================


    CSDN博客地址:https://blog.csdn.net/qq_34115899
  • 相关阅读:
    【原】作一个有自控力的人,开始你的时间规划吧!
    【原】关于Python中setuptools安装的问题
    【原】2014年3月学习进度报告
    【原】2014年1月、2月学习进度报告
    【原】我的2014年学习提升计划
    【原】得心应手小工具开发——IE代理快速切换工具
    【原】从头学习设计模式(七)——适配器模式
    【原】从头学习设计模式(六)——观察者模式
    【原】从头学习设计模式(五)——装饰者模式
    【原】从头学习设计模式(四)——抽象工厂模式
  • 原文地址:https://www.cnblogs.com/lcy0515/p/9179817.html
Copyright © 2011-2022 走看看