zoukankan      html  css  js  c++  java
  • The area

    http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1002&cid=22619




    Problem Description

    Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

    Note: The point P1 in the picture is the vertex of the parabola.


    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

    Output

    For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

    Sample Input

    2
    5.000000 5.000000
    0.000000 0.000000
    10.000000 0.000000
    10.000000 10.000000
    1.000000 1.000000
    14.000000 8.222222
    

    Sample Output

    33.33
    40.69
    

    Hint

    For float may be not accurate enough, please use double instead of float.

    Author

    Ignatius.L


    #include <iostream>
    #include <iomanip>
    using namespace std;
    int main()
    {
        int N;
        cin>>N;
        double a,b,c,k,h,s,x1,x2,x3,y1,y2,y3;
        while(N--)
        {
            
           
               
                cin>>x1>>y1>>x2>>y2>>x3>>y3;
                a=(y2-y1)/((x2-x1)*(x2-x1));
                b=-2*a*x1;
                c=y1-a*x1*x1-b*x1;
                k=(y2-y3)/(x2-x3);
                h=y2-k*x2;
                s=a/3*(x3*x3*x3-x2*x2*x2)+(b-k)/2*(x3*x3-x2*x2)+(c-h)*(x3-x2);
                cout<<setiosflags(ios::fixed)<<setprecision(2)<<s<<endl;
           
        }
        return 0;
    }







  • 相关阅读:
    Redis集群启动脚本
    查看表结构
    MySQL删除冗余数据
    Java中的阶乘
    MySQL中IFNULL,ISNULL和NULLIF
    最小化安装CentOS7后要做的30件事情
    VMware的CentOS部署环境
    CentOS 上的 FirewallD 简明指南
    CentOS安装Java环境
    Linux中一些常用的很巧妙的命令
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387887.html
Copyright © 2011-2022 走看看