zoukankan      html  css  js  c++  java
  • 最长上升子序列输出下标

    FatMouse's Speed
    
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8025    Accepted Submission(s): 3556
    Special Judge
    
    Problem Description
    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
     
    
    Input
    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
    
    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
    
    Two mice may have the same weight, the same speed, or even the same weight and speed. 
     
    
    Output
    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 
    
    W[m[1]] < W[m[2]] < ... < W[m[n]]
    
    and 
    
    S[m[1]] > S[m[2]] > ... > S[m[n]]
    
    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
     
    
    Sample Input
    6008 1300
    6000 2100
    500 2000
    1000 4000
    1100 3000
    6000 2000
    8000 1400
    6000 1200
    2000 1900
     
    
    Sample Output
    4
    4
    5
    9
    7
    

      

    //FatMouse's Speed1160
    //#define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<algorithm>
    #define MAX 1001
    using namespace std;
    struct Mouse{ int w, s, id; };
    Mouse m[MAX];
    int dp[MAX], id[MAX];
    bool cmp(Mouse a, Mouse b){
        if (a.s != b.s){
            return a.s > b.s;
        }
        return a.w < b.w;
    }
    void out(int i){//递归输出下标,,,,太感动了,就是这里纠结了n个小时
    
        if (i== 0)return;
        else out(id[i]);
        cout << m[i].id << endl;
    }
    int main()
    {
        int i, n, j, totle, w, s, pos=0;
        i = 0;
        while (cin >> w >> s){
            ++i;
            m[i].w = w;
            m[i].s = s;
            m[i].id = i;
        }
        sort(m+1, m + i+1, cmp);
        n = i;//老鼠个数
        memset(id, 0, sizeof(id));
        totle = 0;
        for (i = 1; i <= n; i++){
            dp[i] = 1;
            for (j = 1; j < i; j++){
                if (m[j].w<m[i].w && m[j].s>m[i].s){
                    if (dp[i]<dp[j]+1){
                        dp[i] = dp[j]+1;
                        id[i] = j;
                    }
                }
            }
            if (dp[i]>totle){
                totle = dp[i];
                pos = i;
            }
            //totle = max(totle, dp[i]);
        }
    
        cout << totle << endl;
        out(pos);
    
        system("pause");
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    sublime使用及插件
    Unity 查找
    Unity 3D 的四种坐标系
    C#知识点<4>
    C#知识点<3>
    C#知识点<2>
    排序算法
    OOP的三大特性------封装、继承、多态
    C#常用函数
    C++-------------类和对象
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3552969.html
Copyright © 2011-2022 走看看