zoukankan      html  css  js  c++  java
  • Binary Numbers

    描述

     

    Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

    Example
    The positions of 1's in the binary representation of 13 are 0, 2, 3.

    Task
    Write a program which for each data set:
    reads a positive integer n,
    computes the positions of 1's in the binary representation of n,
    writes the result.

    输入

    The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

    Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

    输出

    The output should consists of exactly d lines, one line for each data set.

    Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

    样例输入

    1
    13

    样例输出

     0 2 3

    code:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n, x;
        cin>>n;
        while(n--){
         cin>>x;
         int num=0;
         bool flag = true;
         while(x){
             if(x&1){
                 if(flag){
                    cout<<num;
                    flag = false;
                  }else{
                   cout<<" "<<num;
                  }
             }
               num++;
               x = x>>1;
          }
          cout<<endl;
        }
     return 0;
    }
    

      

  • 相关阅读:
    Delphi6函数大全(1)
    chr码值对应列表大全
    delphi控制POS打印机
    java network programming 第七章
    loop msn 2
    java ftp 资源
    java network programming 第六章
    IM模型的几个概念
    TCP/IP网络互连技术 卷3 winsock篇
    看你网络安全的水平!!
  • 原文地址:https://www.cnblogs.com/lzeffort/p/5924966.html
Copyright © 2011-2022 走看看