zoukankan      html  css  js  c++  java
  • hdu 1078 FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5701    Accepted Submission(s): 2320


    Problem Description
    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
     
    Input
    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.
     
    Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected.
     
    Sample Input
    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1
     
    Sample Output
    37
     
    Source
     time:78ms
    思路:dp[i][j]表示从坐标点(i,j)出发所能走到的路径权值累加和最大
    纠结了几天,看了discuss后才知道一定是直走,比如(x,y)走2步,不会出现(x + 0 + 1, y + 1 + 0)这样的走法
    DAG模型
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <cstdlib>
    #include <algorithm>
    using namespace std ;
    int dir[][2] = {{-1,0},{0,-1},{1,0},{0,1}} ;
    int n, k ;
    int mat[120][120] ;
    int dp[120][120] ;
    void _in()
    {
        for(int i = 0 ; i < n; ++i)
            for(int j = 0; j < n ;++j)
            cin >> mat[i][j] ;
    }
    int getans(int i, int j)
    {
        int& res = dp[i][j] ;
        if(res != -1) return res ;
        res = 0 ;
        for(int x = 1; x <= k ;++x)
        for(int y = 0; y < 4; ++y)
        {
            int ti = i + dir[y][0] * x ;
            int tj = j + dir[y][1] * x ;
            if(ti < 0 || ti >= n || tj < 0 || tj >= n) continue ;
            if(mat[ti][tj] <= mat[i][j]) continue ;
            res = max(res, getans(ti, tj) + mat[ti][tj]) ;
    
        }
        return res ;
    }
    int main()
    {
        //freopen("in.txt","r",stdin) ;
        ios::sync_with_stdio(0) ;
        while(cin >> n >> k)
        {
            _in() ;
            memset(dp, -1, sizeof dp) ;
            if(n == -1 && k == -1) break ;
            cout << getans(0, 0) + mat[0][0] << endl ;
        }
        return 0 ;
    }
  • 相关阅读:
    jQuery火箭图标返回顶部代码
    jQuery火箭图标返回顶部代码
    C#使用BouncyCastle操作国密SM3
    Win10 2004种子
    Excel对比两列数据,找到重复项
    CentOS7 + frp远程访问内网Windows电脑
    Docker on Mac OS
    MySQL5.6中查询多边形包含点情况(ST_Contains、ST_Within)
    SQL查询表的所有字段名
    清除文本中Html的标签
  • 原文地址:https://www.cnblogs.com/orchidzjl/p/4504624.html
Copyright © 2011-2022 走看看