zoukankan      html  css  js  c++  java
  • 1044 Shopping in Mars

    Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

    1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
    2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
    3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

    Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

    If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (105​​), the total number of diamonds on the chain, and M (108​​), the amount that the customer has to pay. Then the next line contains N positive numbers D1​​DN​​ (Di​​103​​ for all i=1,,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print i-j in a line for each pair of i j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

    If there is no solution, output i-j for pairs of i j such that Di + ... + Dj >M with (Di + ... + Dj M) minimized. Again all the solutions must be printed in increasing order of i.

    It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

    Sample Input 1:

    16 15
    3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
    

    Sample Output 1:

    1-5
    4-6
    7-8
    11-11
    

    Sample Input 2:

    5 13
    2 4 5 7 9
    

    Sample Output 2:

    2-4
    4-5
    

    分析请参考【PAT1044】Shopping in Mars 二分法

    注意:该题对时间有限制,需要用改进的算法实现,之前实现了一个O(N^2)级的,三个测试点没过,采用二分法即可解决。

    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    
    static const long int MAX = 100001;
    
    long int n, pay;
    int M[MAX];
    int D[MAX];
    vector<long int> v;
    
    int findBestsum(int i, int n, int ddl){
        int left = i+1;
        int right = n;
        while(left<right){
            int mid = (left+right)/2;
            if(M[mid]-M[i]>=ddl){
                right = mid;
            }
            else{
                left = mid+1;
            }
        }
        D[i] = right;
        return M[right] - M[i];
    }
    
    int main(){
        cin>>n>>pay;
        M[0] = 0;
        for(long int i=1;i<=n;i++){
            cin>>M[i];
            M[i] = M[i] + M[i-1];
        }
        int res;
        int temp = 200000000;
        for(int i=0;i<n;i++){
            res = findBestsum(i, n, pay);
            if(res>=pay){
                if(res<temp){
                    temp = res;
                    v.clear();
                    v.push_back(i);
                }
                else if(res==temp){
                    v.push_back(i);
                }
            }
        }
        for(vector<long int>::iterator it=v.begin();it!=v.end();it++){
            cout<<*it+1<<"-"<<D[*it]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    实用 zsh 插件
    laravel 实用扩展包
    laravel Collection mapToDictionary 例子
    laravel mapSpread 例子
    mac 命令行大杂烩
    iview table中 on-view事件点击无效
    github网站打不开了
    iview table 表头样式修改
    $attrs is readonly
    iview中modal如何修改标题颜色
  • 原文地址:https://www.cnblogs.com/sgatbl/p/9595871.html
Copyright © 2011-2022 走看看