zoukankan      html  css  js  c++  java
  • POJ 1979 Red and Black 四方向棋盘搜索

    Red and Black

    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 50913   Accepted: 27001

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
    The end of the input is indicated by a line consisting of two zeros.

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13

    题意:@是搜索起点,#不能走,.可以走,.走过一次后会变为#,问从@开始在棋盘上一共可以走几步(@起点算一步)

    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    using namespace std;
    int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
    string a[105];
    int n,m,cnt;
    int check(int x,int y)
    {
        if(x>=0&&x<n&&y>=0&&y<m&&a[x][y]!='#')
            return 1;
        else
            return 0;
    }
    void dfs(int x,int y)
    {
        if(check(x,y)==0)
            return ;
        else
        {
            a[x][y]='#';
            cnt++;
            for(int i=0;i<4;i++)
            {
                int dx,dy;
                dx=x+dir[i][0];
                dy=y+dir[i][1];
                dfs(dx,dy);
            }
        }
    }
    int main()
    {
        while(cin>>m>>n&&n&&m)
        {
            for(int i=0;i<n;i++)
                cin>>a[i];
            cnt=0;
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    if(a[i][j]=='@')
                    {
                        dfs(i,j);
                        break;
                    }
                }
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    iOS开发-UIColor和UIImage之间的转换
    iOS开发-给用户好的印象
    iOS开发之国际化(本地化)
    git学习之创建分支和合并分支
    iOS设置StatusBar字体颜色问题
    iOS开发技巧,细节(二)
    iOS开发,[NSBundle mainBundle] pathForResource方法返回空的问题解决
    【MM MRP】PA-SCM525 Unit2 Lot-Size$Rounding Profile(MRP_2)
    【MM MRP】PA-I (MRP_1)
    【MM 发票】MM MIRO界面中的ITEM LIST的布局可自己定义(转)
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11290235.html
Copyright © 2011-2022 走看看