zoukankan      html  css  js  c++  java
  • POJ 1979 Red and Black 四方向棋盘搜索

    Red and Black

    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 50913   Accepted: 27001

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
    The end of the input is indicated by a line consisting of two zeros.

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13

    题意:@是搜索起点,#不能走,.可以走,.走过一次后会变为#,问从@开始在棋盘上一共可以走几步(@起点算一步)

    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    using namespace std;
    int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
    string a[105];
    int n,m,cnt;
    int check(int x,int y)
    {
        if(x>=0&&x<n&&y>=0&&y<m&&a[x][y]!='#')
            return 1;
        else
            return 0;
    }
    void dfs(int x,int y)
    {
        if(check(x,y)==0)
            return ;
        else
        {
            a[x][y]='#';
            cnt++;
            for(int i=0;i<4;i++)
            {
                int dx,dy;
                dx=x+dir[i][0];
                dy=y+dir[i][1];
                dfs(dx,dy);
            }
        }
    }
    int main()
    {
        while(cin>>m>>n&&n&&m)
        {
            for(int i=0;i<n;i++)
                cin>>a[i];
            cnt=0;
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    if(a[i][j]=='@')
                    {
                        dfs(i,j);
                        break;
                    }
                }
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    第三次作业
    第二次作业
    第一次作业
    仪仗队(欧拉函数)
    自己随便做的,没做完就没耐心继续了。呵呵
    从别处见到一位大神的代码 飞扬的小鸟(flappy bird)
    简易迷宫游戏c++
    STL做法 平衡树
    基于百度地图api + AngularJS 的入门地图
    javascript 简易文本编辑器
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11290235.html
Copyright © 2011-2022 走看看