zoukankan      html  css  js  c++  java
  • 1113. Integer Set Partition (25)

    Given a set of N (> 1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that |n1 - n2| is minimized first, and then |S1 - S2| is maximized.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives an integer N (2 <= N <= 105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

    Output Specification:

    For each case, print in a line two numbers: |n1 - n2| and |S1 - S2|, separated by exactly one space.

    Sample Input 1:
    10
    23 8 10 99 46 2333 46 1 666 555
    
    Sample Output 1:
    0 3611
    
    Sample Input 2:
    13
    110 79 218 69 3721 100 29 135 2 6 13 5188 85
    
    Sample Output 2:
    1 9359
    

    首先要保证n1和n2相差最小无非是相差0或者1,也就是n是偶数或者是奇数,然后再保证s1和s2相差最大,排个序,从中间分开即可。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int s[100005];
    int n;
    int main()
    {
        cin>>n;
        for(int i = 0;i < n;i ++)
        {
            cin>>s[i];
        }
        sort(s,s + n);
        int sum = 0;
        for(int i = 0;i < n / 2;i ++)
            sum += s[n - i - 1] - s[i];
        if(n % 2)
        {
            cout<<1<<' '<<sum + s[n / 2];
        }
        else cout<<0<<' '<<sum;
    }
  • 相关阅读:
    一轮项目冲刺9
    一轮项目冲刺8
    一轮项目冲刺7
    一轮项目冲刺6
    一轮项目冲刺5
    一轮项目冲刺4
    一轮项目冲刺3
    一轮项目冲刺2
    一轮项目冲刺1
    移山小分队---每日记录01
  • 原文地址:https://www.cnblogs.com/8023spz/p/8491538.html
Copyright © 2011-2022 走看看