zoukankan      html  css  js  c++  java
  • POJ 1328 Radar Installation


    Radar Installation
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 41153Accepted: 9125

    Description

    Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

    We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
    POJ 1328 Radar Installation - qhn999 - 码代码的猿猿 
    Figure A Sample Input of Radar Installations


    Input

    The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

    The input is terminated by a line containing pair of zeros 

    Output

    For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

    Sample Input

    3 2
    1 2
    -3 1
    2 1

    1 2
    0 2

    0 0

    Sample Output

    Case 1: 2
    Case 2: 1

    Source




    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <algorithm>

    using namespace std;

    int n;double d;
    struct Node
    {
        double left,right;
    }island[1111];

    bool cmp(Node a,Node b)
    {
        return a.left-b.left<1e-6;
    }

    int main()
    {
        int cas=0;double x,y;
    while(scanf("%d%lf",&n,&d))
    {
        memset(island,0,sizeof(island));

        if(n==0) break;
        int possible=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&x,&y);
            if(y>d||d<0) possible=0;
            double temp=sqrt(d*d-y*y);
            island.left=x-temp;
            island.right=x+temp;
        }

        if(possible==0)
        {
            printf("Case %d: -1 ",++cas);
            continue;
        }

        sort(island,island+n,cmp);

        int ans=1;
        Node pre=island[0];
        for(int i=1;i<n;i++)
        {
            if(island.left-pre.right>1e-6)
            {
                ans++;
                pre=island;
            }
            else
            {
                if(island.right-pre.right<1e-6)
                {
                    pre=island;
                }
            }
        }

         printf("Case %d: %d ",++cas,ans);
    }
        return 0;
    }

  • 相关阅读:
    BUUCTF [XMAN2018排位赛]四道misc题汇总
    祥云杯2020 Misc题解
    win10更换pip源
    BUUCTF N1BOOK配套题目
    kali下docker安装教程
    湖湘杯2020 Misc题解
    7号夺宝1元购iPhone6s 1元众筹怎么玩
    html5 的服务器推送 Server-sent Events和 websocket这两个是不是同一个东西,是两个不同的?
    WebSocket 是什么原理?为什么可以实现持久连接?
    使用HTML5的十大原因
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350988.html
Copyright © 2011-2022 走看看