zoukankan      html  css  js  c++  java
  • POJ 1915

    Knight Moves
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 21791   Accepted: 10155

    Description

    Background 
    Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
    The Problem 
    Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
    For people not familiar with chess, the possible knight moves are shown in Figure 1. 

    Input

    The input begins with the number n of scenarios on a single line by itself. 
    Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

    Output

    For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

    Sample Input

    3
    8
    0 0
    7 0
    100
    0 0
    30 50
    10
    1 1
    1 1

    Sample Output

    5
    28
    0

    Source

    TUD Programming Contest 2001, Darmstadt, Germany
     
    BFS
    #include <iostream>
    #include <queue>
    #include <cstring>
    using namespace std;
    class Node{
    public:
        int x ;
        int y ;
        int d ;
    
        void init(int nx , int ny , int nd){
            x = nx ;
            y = ny ;
            d = nd ;
        }
    };
    const int MAXN = 301;
    bool visit[MAXN][MAXN] ;
    int dir[8][2]={{1,2},{2,1},{2,-1},{1,-2},{-1,2},{-2,1},{-1,-2},{-2,-1}};
    int m;
    int bfs(Node source , Node target){
            queue<Node> Q ;
            source.d = 0  ;
            Q.push(source);
            memset(visit , 0 , sizeof(visit)) ;
            visit[source.x][source.y] = 1 ;
            while(!Q.empty()){
                Node a = Q.front() ;
                Q.pop() ;
                int x = a.x ;
                int y = a.y ;
                for(int i = 0 ; i < 8 ; i ++){
                    int nx = x + dir[i][0] ;
                    int ny = y + dir[i][1] ;
    
                    if(nx < 0 || nx >= m || ny >= m || ny < 0)
                        continue ;
                    if(visit[nx][ny])
                        continue ;
                    if(target.x == nx && target.y == ny)
                        return a.d + 1 ;
                    visit[nx][ny] = 1 ;
                    Node c ;
                    c.init(nx , ny , a.d + 1);
                    Q.push(c) ;
                }
            }
    }
    
    int main()
    {
        int t;
        cin.sync_with_stdio(false);
        cin>>t;
        while(t--)
        {
            cin>>m;
            int x,y;
            cin>>x>>y;
            Node begin,end;
            begin.init(x,y,0);
            cin>>x>>y;
            end.init(x,y,0);
            if(begin.x==end.x&&begin.y==end.y)
            {
                cout<<"0"<<endl;
                continue;
            }
            cout<<bfs(begin,end)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Mysql数据库(三)Mysql表结构管理
    Mysql数据库(二)Mysql数据库管理
    Mysql数据库(一)数据库设计概述
    设计模式(二十三)Interpreter模式
    设计模式(二十二)Command模式
    设计模式(二十一)Proxy模式
    设计模式(二十)Flyweight模式
    python 全局变量
    python 装饰器
    python 文件读写
  • 原文地址:https://www.cnblogs.com/Run-dream/p/3878027.html
Copyright © 2011-2022 走看看