zoukankan      html  css  js  c++  java
  • Just a Hook(区间更新+区间和)

    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.

    InputThe input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
    OutputFor each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
    Sample Input

    1
    10
    2
    1 5 2
    5 9 3

    Sample Output

    Case 1: The total value of the hook is 24.
    #include <iostream>
    using namespace std;
    const int N = 5*1e5+5;
    #define ls now<<1
    #define rs now<<1|1
    #define lli long long
    #define ok return 0;
    #define TLE std::ios::sync_with_stdio(false);cin.tie(NULL);cout.tie(NULL);
    typedef struct node
    {
        lli val,lazy,l,r,mx,mn;
    }node;
    node dp[N<<2];
    int a[N];
    void pushup(int now) {dp[now].val = dp[ls].val+dp[rs].val;return ;}
    void build(int now,int l,int r)
    {
        dp[now].l=l; dp[now].r=r; dp[now].lazy=1; dp[now].val=1;
        if(l==r) {return ;}
        int mid = (r+l)>>1;
        //cout<<"mid=====      " << mid <<endl;
        build(ls,l,mid);
        build(rs,mid+1,r);
        pushup(now);
    }
    void pushdown(int now)
    {
        if(dp[now].lazy)
        {
            dp[ls].lazy = dp[now].lazy;
            dp[rs].lazy = dp[now].lazy;
            dp[ls].val = dp[now].lazy*(dp[ls].r-dp[ls].l+1);
            dp[rs].val = dp[now].lazy*(dp[rs].r-dp[rs].l+1);
            dp[now].lazy = 0;
        }
    }
    lli query(int now,int l,int r)
    {
        if(dp[now].l>=l && dp[now].r<=r)
            {/*cout<<"+++++"<<endl;*/return dp[now].val;}
        pushdown(now);
        lli mid = ( dp[now].l+dp[now].r )>>1;
        long long cnt=0;
        if(l<=mid)
            cnt+=query(ls,l,r);
        if(r>mid)
            cnt+=query(rs,l,r);
        return cnt;
    }
    void updata(int now,int l,int r,lli k)
    {
        if(dp[now].l>=l && dp[now].r<=r)
        {
            dp[now].lazy=k;
            dp[now].val=(dp[now].r-dp[now].l+1)*k;
            return ;
        }
        pushdown(now);
        int mid = ( dp[now].l+dp[now].r )>>1;
        if(l<=mid) updata(ls,l,r,k);
        if(r>mid)  updata(rs,l,r,k);
        pushup(now);
    
    }
    int main()
    {
        TLE;
        int t;
        cin>>t;
        lli n,m,lll,rrr,k;
        for(int kk=1;kk<=t;kk++)
        {
            cin>>n>>m;
            //for(int i=1;i<=n;i++) cin>>a[i];
            build(1,1,n);
            string str;
            for(int i=0;i<m;i++)
            {
                cin>>lll>>rrr>>k;
                updata(1,lll,rrr,k);
            }
            cout<<"Case "<<kk<<": The total value of the hook is "<<query(1,1,n)<<"."<<endl;
        }
        ok;
    }
    所遇皆星河
  • 相关阅读:
    Quickuse.Ioc 快速应用.依赖注入组件
    Quickuse.Utility 快速应用.基础组件
    对System.ComponentModel.DataAnnotations 的学习应用
    C# List 转 Tree 公共方法
    C# 用Redis实现的分布式锁
    使用DbTableColumnWeb项目简要
    Application_Error VS OnException 遇到的坑
    在使用Intelligencia.UrlRewriter过程中 中文乱码问题
    C# MVC 页面静态化导致的问题
    关于.NetCore与.Netframework 对于DataSet的序列化与反序列化问题的探讨.
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11470058.html
Copyright © 2011-2022 走看看