zoukankan      html  css  js  c++  java
  • AtCoder-3920

    We have a 3×3 grid. A number ci,j is written in the square (i,j), where (i,j) denotes the square at the i-th row from the top and the j-th column from the left.
    According to Takahashi, there are six integers a1,a2,a3,b1,b2,b3 whose values are fixed, and the number written in the square (i,j) is equal to ai+bj.
    Determine if he is correct.

    Constraints

    • ci,j (1i3,1j3) is an integer between 0 and 100 (inclusive).
    Input

    Input is given from Standard Input in the following format:

    c1,1 c1,2 c1,3
    c2,1 c2,2 c2,3
    c3,1 c3,2 c3,3
    
    Output

    If Takahashi's statement is correct, print Yes; otherwise, print No.

    Sample Input 1

    1 0 1
    2 1 2
    1 0 1
    
    Sample Output 1

    Yes
    

    Takahashi is correct, since there are possible sets of integers such as:a1=0,a2=1,a3=0,b1=1,b2=0,b3=1.

    Sample Input 2

    2 2 2
    2 1 2
    2 2 2
    
    Sample Output 2

    No
    

    Takahashi is incorrect in this case.

    Sample Input 3

    0 8 8
    0 8 8
    0 8 8
    
    Sample Output 3

    Yes
    
    Sample Input 4

    1 8 6
    2 9 7
    0 7 7
    
    Sample Output 4

    No


    题解:这一题由于给的数据范围不大,所以可根据关系式,遍历每个整数A;看是否找到使关系式成立的A。如有,则输出Yes,否则输出No

    AC代码为:

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;


    int a[4][4];
    int main()
    {
    for (int i = 1; i <= 3; i++)
    {
    for (int j = 1; j <= 3; j++)
    {
    cin >> a[i][j];
    }
    }
    int flag = 1;
    for (int k = -1000; k <= 1000; k++)
    {
    int a2, a3, b1, b2, b3;
    int a1 = k;
    b1 = a[1][1] - k;
    b2 = a[1][2] - k;
    b3 = a[1][3] - k;
    a2 = a[2][1] - b1;
    a3 = a[3][1] - b1;
    if (a[2][2] != a2 + b2) flag = 0;
    if (a[2][3] != a2 + b3) flag = 0;
    if (a[3][2] != a3 + b2) flag = 0;
    if (a[3][3] != a3 + b3) flag = 0;
    if (flag)
    {
    break;
    }
    }
    if (flag)
    cout << "Yes" << endl;
    else
    cout << "No" << endl;
    return 0;
    }



  • 相关阅读:
    BZOJ 1021 循环的债务
    BZOJ 1019 汉诺塔
    BZOJ 1018 堵塞的交通
    BZOJ 1017 魔兽地图
    BZOJ 1016 最小生成树计数
    Luogu 3008 [USACO11JAN]道路和飞机Roads and Planes
    Luogu 3625 [APIO2009]采油区域
    Luogu 4139 上帝与集合的正确用法
    Luogu 3629 [APIO2010]巡逻
    Luogu 3626 [APIO2009]会议中心
  • 原文地址:https://www.cnblogs.com/csushl/p/9386609.html
Copyright © 2011-2022 走看看