zoukankan      html  css  js  c++  java
  • [ACM] POJ 3253 Fence Repair (Huffman树思想,优先队列)

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 25274   Accepted: 8131

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    Source


    解题思路:

    对所输入的数据构造Huffman树,当中非叶子节点的值加起来的和为所求。

    Huffman树的构造过程: 每次取全部数中的两个最小数,相加起来得到一个非叶子节点的值,下次取的时候曾经取过的两个最小数数不能再取。再相加得到非叶子节点的值能够取。

    比方 3 , 4 。 5  。先取  3 ,4 相加为 7 。 然后取 5 ,7(3,4取过不能再取了),相加为12,    7+12 =19,即为所求。

    优先队列能够非常好的实现这个操作。

    定义int类型优先级从小到大的代码为:

    priority_queue<int ,vector<int>,greater<int> > q


    代码:

    #include <iostream>
    #include <queue>
    using namespace std;
    int main()
    {
        priority_queue<int ,vector<int>,greater<int> > q;
        int n;
        int num;
        cin>>n;
        while(n--)
        {
            cin>>num;
            q.push(num);
        }
        long long sum=0;
        
        while(!q.empty())
        {
            int n1=q.top();
            q.pop();
            int n2=q.top();
            q.pop();
            sum+=n1+n2;
            if(q.empty())
                break;
            q.push(n1+n2);
        }
        
        cout<<sum<<endl;
        return 0;
    }
    


  • 相关阅读:
    SSH移植
    ARM PPC 交叉编译环境搭建
    CEOI2020 作战记录&题解
    [NOI2019]序列 题解
    Atcoder Dwango Programming Contest 6th 题解
    CF516D Drazil and Morning Exercise 题解
    CF568E Longest Increasing Subsequence 题解
    [IOI2013]robots 题解
    SPOJ22549 DIVFACT4
    CF590E Birthday 题解
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/7218740.html
Copyright © 2011-2022 走看看