zoukankan      html  css  js  c++  java
  • HDU 4190 Distributing Ballot Boxes (二分答案)

    题面

    Problem Description
    Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
    The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
    The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
    In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.

    Input
    The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer ai,(1<=ai<=5,000,000), indicating the population of the ith city.
    A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.

    Output
    For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.

    Sample Input
    2 7
    200000
    500000

    4 6
    120
    2680
    3400
    200

    -1 -1

    Sample Output
    100000
    1700

    思路

    求最大值的最小值,很容易想到二分答案,对于二分答案来说,最重要的就是那个判断函数,这也是具体问题的分析点。那么我们具体来想这个问题,首先,当n=m的时候,这个时候无论你怎么投票,最小的票数一定是那个最大城市的人数,这点十分显然,如果想证的话,也可以去试试看证明。我们考虑不相等的情况,这个时候我们就要去二分容量,然后用每一个城市的人数对这个容量向上取整,就得出了这个容量下需要的最少盒子数目,我们根据这个盒子数去和投票箱的数目进行对比,继续二分,最后就是答案了。

    代码实现

    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<iostream>
    using namespace std;
    #define eps 1e-4
    const int maxn=10005;
    int city, box, sum;
    bool flag;
    int a[maxn], best;
    int main () {
       while (cin>>city>>box) {
          if (city==-1&&box==-1) break;
          for (int i=1;i<=city;i++) {
             cin>>a[i];
             best = max(best,a[i]);
          }
          if (city==box) {
             cout<<best<<endl;
             continue;
          }
          int left=1, right=best, mid;
          while (left<right) {
             flag=true;
             sum=0;
             mid=(left+right)>>1;
             for (int i=1;i<=city;i++) {
                 sum+=ceil(a[i]*1.0/mid);
                 if (sum>box) flag=false;
             }
             if (flag) right=mid;
             else left=mid+1;
          }
          cout<<left<<endl;
       }    
        return 0;
    }
    
  • 相关阅读:
    GO 文档笔记
    GO 切片实力踩坑
    关于接口设计的一些反思
    Jenkins 发布.net core 程序,服务端无法下载nuget包的解决方法 error NU1102: 找不到版本为 (>= 3.1.6) 的包
    RabbitMQ 基础概念进阶
    RabbitMQ 入门之基础概念
    Object.entries()使用
    shadow的属性值介绍
    行内元素的特别之处
    margin的特别之处
  • 原文地址:https://www.cnblogs.com/hhlya/p/13113687.html
Copyright © 2011-2022 走看看