zoukankan      html  css  js  c++  java
  • Milk

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 20   Accepted Submission(s) : 12

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

    Output

    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

    Sample Input

    2
    2
    Yili 10 500
    Mengniu 20 1000
    4
    Yili 10 500
    Mengniu 20 1000
    Guangming 1 199
    Yanpai 40 10000
    

    Sample Output

    Mengniu
    Mengniu
    

    Hint

    In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case,
    milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
    #include<iostream>
    #include<string>
    using namespace std;
    struct node
    {
        string na;
        int p,v;
        double w;
    }a[1005];
    int main()
    {
        int t,n;
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(int i=1;i<=n;i++)
                {
                    cin>>a[i].na>>a[i].p>>a[i].v;
                    if(a[i].v>=1200)
                        a[i].w=a[i].p/5;
                    else if(a[i].v>=200)
                    {
                        int x=a[i].v/200;
                        a[i].w=a[i].p/double(x*1.0);
                    }
                    else a[i].w=-1;
                }
                double minx=0x7777777;
                int k;
                for(int j=1;j<=n;j++)
                {
                    if(a[j].w!=-1)
                    {
                        if(a[j].w<minx)
                        {
                            minx=a[j].w;
                            k=j;
                        }
                    }
                }
            cout<<a[k].na<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    数据结构与算法分析(1)引论
    每天一个Linux命令(1)ls命令
    Oracle ->> 层级查询语句(hierarchical query)connect by
    SQL Server ->> GROUPING SETS, CUBE, ROLLUP, GROUPING, GROUPING_ID
    Oracle ->> 日期函数
    Oracle ->> 变量赋值 Demo
    SQL SERVER ->> BCP导出数据到平面文件
    SQL SERVER ->> CXPacket等待类型
    SQL SERVER ->> Wait Stats
    SQL SERVER ->> Columnstore Index
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5732098.html
Copyright © 2011-2022 走看看