zoukankan      html  css  js  c++  java
  • Babelfish_map映射

    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 41068   Accepted: 17495

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<string>
    #include<map>
    using namespace std;
    int main()
    {
        char a[12],b[12];
        map<string,bool>vis;
        map<string,string>trans;
        char ch;
        while(1)
        {
            ch=getchar();
            if(ch=='
    ') break;//是空行的话,字典的输入部分结束
            else
            {
                a[0]=ch;
                int i=1;
                while(1)
                {
                    ch=getchar();
                    if(ch==' ')//是空的话,原单词的输入结束
                    {
                        a[i]='';
                        break;
                    }
                    else a[i++]=ch;
                }
            }
    
            cin>>b;
            getchar();//吃掉回车键
            vis[b]=true;
            trans[b]=a;
        }
        char sh[12];
        while(cin>>sh)
        {
            if(vis[sh])
            {
                cout<<trans[sh]<<endl;
            }
            else cout<<"eh"<<endl;
        }
    
        return 0;
    }
  • 相关阅读:
    Ambari 整体架构
    Ambari 介绍
    xcode工程命令行生成ipa安装包
    gradle打包java项目
    FreeMarker标签介绍
    P与NP,从概念到研究全面综述
    计算机领域经典笑话
    自己动手写GC
    编程语言简史
    不第后赋菊
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5791246.html
Copyright © 2011-2022 走看看