zoukankan      html  css  js  c++  java
  • HDU-1020 Encoding

    Descripe

    Given a string containing only 'A' - 'Z', we could encode it using the following method: 

    1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

    2. If the length of the sub-string is 1, '1' should be ignored.

    Input

    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

    Output

    For each test case, output the encoded string in a line.

    Sample Input

    2

    ABC

    ABBCCC

    Sample Output

    ABC

    A2B3C


    #include <iostream>
    using namespace std;
    
    int main(void)
    {
        char a[10002];
        int t;
        pair<int, char> b[1000];
        
        while(cin >> t)
        {
            while(t--)
            {
                int i = 0;
                int n = 0;
                
                cin >> a;
                if(strlen(a)==1)
                {
                    cout << a << endl;
                    continue;
                }
                for( ; a[i]!=''; i++)
                {
                    if(i==0 || a[i]!=a[i-1])
                    {
                        b[n].first = 0;
                        b[n].second = a[i];
                    }
                    if(a[i]!=a[i+1])
                    {
                        b[n++].first++;
                        continue;
                    }
                    b[n].first++;
                }
                for(i = 0; i < n; i++)
                {
                    if(b[i].first!=1)
                        cout << b[i].first;
                    cout << b[i].second;
                }
                cout << endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    linux基础命令之一
    Chrome 控制台使用大全
    移动端效果 — 页面引入在线视频
    移动端——简单计分表单
    JS操作cookie
    移动端页面字体——rem的使用
    Highcharts 使用总结
    CSS水平居中
    python学习 day2
    python学习 day1
  • 原文地址:https://www.cnblogs.com/limyel/p/6691466.html
Copyright © 2011-2022 走看看